Jump to content
UltiMaker Community of 3D Printing Experts

Creality cr10s. No extrusion! Complicated problem.


Geekswede
 Share

Recommended Posts

Posted · Creality cr10s. No extrusion! Complicated problem.

Hi! Going to try to keep it short.

My printer:

Creality cr10s

Direct drive extruder (swiss) 

Silent motherboard

Flashed Marlin 

 

So it doesn't extrude. The problem started before i switched motherboard. 

I've tried to run the extruder with the x,y and z "cables" and that works fine.

So it isn't anything wrong with the motor, nossle or anything like that. 

 

Im running Cura, currently 4.13 (beta) 

I've tried everything from Cura 4.8 and to 4.13. 

I've have checked the gcode and it looks Right, I've tried "old" gcode files that have worked before but no luck.

What happens? Well nothing BUT it makes a "click" sometimes in the beginning of the print and backs the gear a little, like it retracts. Sounds like when the extruder is struggling with to much resistance. 

But there's no resistance, no problem there. 

 

 

Does someone have any idea?

 

 

  • Link to post
    Share on other sites

    Posted · Creality cr10s. No extrusion! Complicated problem.

    When you swapped cables did you try any other motors with the E cable?

    You re-calibrated the Esteps after changing the extruder?  Also after changing the mainboard?

    Did you happen to go with a pancake motor for the extruder?

     

    The attached file "test.gcode" contains the following:

     

    G28 ;auto-home all
    G1 F2100 Z100 ;move up 100mm
    M302 S0 ;turn off cold extrusion prevention
    G92 E0 ;reset the extruder to 0
    G1 F600 E100 ;extrude 100mm of filament
    M400 ;finish all moves
    M302 S175 ;reset cold extrusion prevention

     

    With your E motor correctly wired and the nozzle removed (there is no heating) print the file.  The code is simply telling the printer to push 100mm of filament.

    If it doesn't work then the problem may be in the cable, or in the plug on either the motor or the motherboard.

     

    test.gcode

  • Link to post
    Share on other sites

    Posted · Creality cr10s. No extrusion! Complicated problem.

    Thank you sir for taking your time to help me! It works now and it was the cable!.

     

    Yes i did try another motor with the E cable and then it workt😅 

     

    Dont have a pancake motor yet! Do you advised against?

    I would like to try it so i can get the "moving wheight" down.

     

    So anyway i felt that I've tried everything. But with your test code i decided to try again, it was so much easier with that. And pretty soon i find that it was the cable. 

     

    Thank you again! Much appreciated! 

    /GeekSwede

     

  • Link to post
    Share on other sites

    Posted · Creality cr10s. No extrusion! Complicated problem.

    Taa-Daaa!  Congratulations.

    If I had a need to print more TPU models I would consider a Direct Drive.  My bowden printer hates TPU and I limit myself to flat gaskets and things.

    A pancake stepper would lower the weight but from what I've read the lower torque can be a problem and limits the speed you can print.  If there is going to be a limit then you may as well stay with what you have and see how it goes.  Something to consider is putting a line into your StartUp Gcode like (Ex.) M201 X300.  The M201 is "Max Acceleration" so in that example X300 would limit the X to 300mm/sec² accell.  You may find you don't need it but if there are marks showing up in the print from hard stops and starts of the X axis then it would be something to consider.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Here it is. The new UltiMaker S7
        The UltiMaker S7 is built on the success of the UltiMaker S5 and its design decisions were heavily based on feedback from customers.
         
         
        So what’s new?
        The obvious change is the S7’s height. It now includes an integrated Air Manager. This filters the exhaust air of every print and also improves build temperature stability. To further enclose the build chamber the S7 only has one magnetically latched door.
         
        The build stack has also been completely redesigned. A PEI-coated flexible steel build plate makes a big difference to productivity. Not only do you not need tools to pop a printed part off. But we also don’t recommend using or adhesion structures for UltiMaker materials (except PC, because...it’s PC). Along with that, 4 pins and 25 magnets make it easy to replace the flex plate perfectly – even with one hand.
         
        The re-engineered print head has an inductive sensor which reduces noise when probing the build plate. This effectively makes it much harder to not achieve a perfect first layer, improving overall print success. We also reversed the front fan direction (fewer plastic hairs, less maintenance), made the print core door magnets stronger, and add a sensor that helps avoid flooding.
         

         
        The UltiMaker S7 also includes quality of life improvements:
        Reliable bed tilt compensation (no more thumbscrews) 2.4 and 5 GHz Wi-Fi A 1080p camera (mounted higher for a better view) Compatibility with 280+ Marketplace materials Compatibility with S5 project files (no reslicing needed) And a whole lot more  
        Curious to see the S7 in action?
        We’re hosting a free tech demo on February 7.
        It will be live and you can ask any questions to our CTO, Miguel Calvo.
        Register here for the Webinar
          • Like
        • 11 replies
      • UltiMaker Cura 5.3.0-Alpha 🎄 Tree Support Spotlight 🎄
        Are you a fan of tree support, but dislike the removal process and the amount of filament it uses? Then we would like to invite you to try this special release of UltiMaker Cura. Brought to you by our special community contributor @thomasrahm
         
        We generated a special version of Cura 5.2 called 5.3.0 Alpha + Xmas. The only changes we introduced compared to UltiMaker Cura 5.2.1 are those which are needed for the new supports. So keep in mind, this is not a sneak peek for Cura 5.3 (there are some really cool new features coming up) but a spotlight release highlighting this new version of tree supports.  
          • Like
        • 17 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...