Jump to content

Unable to open cura. Stuck on "Loading UI"


Recommended Posts

Posted · Unable to open cura. Stuck on "Loading UI"

What happens is that when I attempt to open cura it goes through its first couple things just fine but always gets stuck on "Loading UI" and eventually I have to force close it since it is no longer responding. Looking at the log file (which is attached) it always stops at the same point however I don't know enough about it to really understand what is happening. 

Secondary issue I have noticed which I am pretty sure is at least related to cura is that when I restarted my computer, for several minutes, file explorer didn't work properly. Essentially once I opened the first folder everything on the left bar (quick access and the rest) don't show up and after that I can't even open other folder and have to force close file explorer at which point I could no longer open any folders. However, after several minutes file explorer opens all the folders I had tried to open all at once and then works just like normal. 

This is the second time I have attempted to install cura on my laptop, the first time was last summer and I ran into this same exact issue (I believe that was on version 4.10) ended up just uninstalling cura since I didn't really need it (had it installed on another computer).

Razer Blade 15 Advanced (Early 2020)
OS: Windows 10 Home
CPU: i7-10875H
GPU: RTX 2080 Super MaxQ (Usually smart switches workload with CPU UHD graphics to minimize power consumption but I turned this off so it was dedicated GPU only and the same issue still occurs)

Any suggestions for what I should try in order to fix this would be much appreciated. 


  • Link to post
    Share on other sites

    Posted (edited) · Unable to open cura. Stuck on "Loading UI"
    4 hours ago, nallath said:

    Do you have a network drive mounted? If so, could you unmount it? It's a known issue that this can cause problems.

    The network drive was indeed the problem. Unmounted it and cura opens just like normal. 

    Thank you very much

    Edited by Nicholas7543
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
          • Like
        • 26 replies
    • Create New...