Jump to content

Not saving as gcode?


pishta

Recommended Posts

Posted · Not saving as gcode?

Cura 5.0.0(AppImage) running on linux Mint 20.3. I can open STL files but when I slice and try to save as a gcode (save as gcode) it saves the file with no suffix, ie. "bug.stl" will slice and <save to disk (USB) as gcode> will generate a file called "bug" with no file type and it will have properties as -Text (text/plain)- and open with text editor

 

;FLAVOR:Marlin
;TIME:0
;Filament used: 0m
;Layer height: 0.16
;MINX:2.14748e+06
;MINY:2.14748e+06
;MINZ:2.14748e+06
;MAXX:-2.14748e+06
;MAXY:-2.14748e+06
;MAXZ:-2.14748e+06
;Generated with Cura_SteamEngine 5.0.0
M140 S60

...

...

 

I have other gcode files on this USB and they will show up in the Ender 3 display but it will not show "bug" as it thinkgs its a text file. I have tried to change the name to bug.gcode but that file will not print, the printer will just show question marks in the coordinates. Most of the other gcode files in this USB end up being called "CE3PRO_xxx.gcode" with the CE3PRO being added by the slicing program? IF there is a native linux slicing program that may work better than Cura let me know. 

  • Link to post
    Share on other sites

    • 3 months later...
    Posted · Not saving as gcode?

    HI, Im not sure if you have managed to solve the issue but i have experienced the same problem. If you rename the file with .gcode suffix it should do the trick

    Thats what worked for me but make sure its sliced first.

  • Link to post
    Share on other sites

    • 2 weeks later...
    Posted · Not saving as gcode?

    Hey @Dan15h and @pishta,

     

    Welcome to the Ultimaker Community 🎉

     

    I think I recognize this issue, I believe it's been reported on our Github here:
    https://github.com/Ultimaker/Cura/issues/12659
    We have a ticket on our backlog with the intent to improve this behavior.

    Thanks for helping out @Dan15h 💕

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
         
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    ×
    ×
    • Create New...