Jump to content

Cura 5.1 slicing hangs or is taking a really long time. What can I do?


burhop

Recommended Posts

Posted · Cura 5.1 slicing hangs or is taking a really long time. What can I do?

I have a model that when I go to slice it, it just hangs with the CPU pegged at 100% at about 1.3 Gig of memory used. After about 15 minutes, I'm here:

image.png.828da4033f4812d5ab4a3f8c1bf46c89.png

 

I'd give out the model but its a confidential.  Is this normal for complex models?  If not, anyway to check for errors or check the file?  It seems to load just fine into Cura, our CAD software and Meshlab. Meshlab says it has 4mill faces so size could be the problem.

  • Link to post
    Share on other sites

    Posted · Cura 5.1 slicing hangs or is taking a really long time. What can I do?

    There is an often reported slicing bug in 5.1 running on Windows systems.  (I was getting real tired of explaining it over on GitHub.)

    If you are running Windows I would suggest that you move to the 5.2beta version which so far (it's only been a few days) seems much better.  (The Linux version of 5.2beta is getting some hits about a slicing bug.)

    A workaround for the bug seems to be to move and/or rotate the model on the Cura build plate.  I guess when the slicing is done from a different direction it can fool the bug(?).  Any way, that worked quite often.

     

    That is a large model.  Windows has a program MS 3D Builder which has a repair function and a "Simplify" tool.  I'm seeing some models lately that are extremely high resolution and well beyond what FDM is capable of.  Making the model simpler will result in more "faceting" but again, the nozzle wasn't going to follow .0000001mm line segments anyway.

  • Link to post
    Share on other sites

    Posted (edited) · Cura 5.1 slicing hangs or is taking a really long time. What can I do?

    I let it run for about 45 minutes and it finally finished.  So it is not hung, just  s l o w w w w . I rotated it by 30 degrees but still had the problem. Also tried 3MF (just facets, no extensions) with the same problem.

     

    You are right about it being overly precise.  I just hate tuning my STLs for where it is going to be used and Cura generally deals with it ok (just not today 😞 )  But it didn't crash and I did finally get some gcode so that is good 🙂 

    Edited by burhop
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 7 replies
      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
    ×
    ×
    • Create New...