Jump to content

Windows 11 file type association problem


JonasGrumby
Go to solution Solved by JonasGrumby,

Recommended Posts

Posted · Windows 11 file type association problem

I'm unable to create file type associations for .gcode and .stl using Cura 5.2.1 on Windows 11. I have tried using Setting > Apps > Default Apps and I have tried right-clicking a file and choosing "open with". I have set Cura as the "default app" and still when I click one of these files it doesn't launch Cura. Instead I get this dialog box and clicking "Just Once" also doesn't launch Cura. Also the Cura icon is not displaying correctly in the dialog. Any ideas? Thanks.

 

open-with-09.jpg

  • Link to post
    Share on other sites

    • 4 months later...
    • Solution
    Posted · Windows 11 file type association problem

    @eremef

     

    Thanks. It's not that simple. It's a registry problem. I had to run a run a .reg file like this. I have to do it again now that Cura v6 is out...


     

    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\.stl\OpenWithProgids]
    ".stl.4.13"=-
    
    [-HKEY_CLASSES_ROOT\.stl.4.13]
    
    [HKEY_CLASSES_ROOT\.stl]
    @="Cura.model"
    
    [HKEY_CLASSES_ROOT\Cura.model]
    @="Standard Tessellation Language (STL) files"
    
    [HKEY_CLASSES_ROOT\Cura.model\DefaultIcon]
    @="C:\\Program Files\\Ultimaker Cura 5.2.1\\Ultimaker-Cura.exe,0"
    
    [HKEY_CLASSES_ROOT\Cura.model\shell]
    @="open"
    
    [HKEY_CLASSES_ROOT\Cura.model\shell\open]
    @="Open with Ultimaker Cura 5.2.1"
    
    [HKEY_CLASSES_ROOT\Cura.model\shell\open\command]
    @="C:\\Program Files\\Ultimaker Cura 5.2.1\\Ultimaker-Cura.exe \"%1\""
    
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.stl]
    
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.stl\OpenWithProgids]
    "Cura.model"=hex(0):

     

  • Link to post
    Share on other sites

    Posted (edited) · Windows 11 file type association problem

    Solved:

     

    I used Ctrl+F to Find all instances of "Cura" in the Registry Editor.

     

    In every case where 5.3.1 existed along side 5.4.0, I deleted the 5.3.1 version.

     

    In every case where 5.3.1 existed without a 5.4.0 equivalent, I modified it by only changing the "3.1" to "4.0".

     

    This worked for me without doing anything additional.  Good luck.

     

     

    Edited by lee-EB
    I resolved the issue.
  • Link to post
    Share on other sites

    Posted · Windows 11 file type association problem

    I did something similar to Jonas' solution above by verifying the existing registry entries. I saw that some looked weird, deleted those keys, downloaded the .MSI install and reinstalled. It works now.

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 7 replies
      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
    ×
    ×
    • Create New...