Jump to content

Dual Extruder, I want to print on the second extruder but the tool never gets called up


Erosion139
Go to solution Solved by GregValiant,

Recommended Posts

Posted (edited) · Dual Extruder, I want to print on the second extruder but the tool never gets called up

Hello, I have been battling this issue for a few days. 


I am running two Raise3D Pro2's and have successfully gotten it to work with Cura for using a main material on T0 and support materials on T1. But I am now stuck on the problem of me wanting to print with only the second nozzle (T0.) Inside the machine settings under start Gcode one of the last lines calls T0 before the main code gets going, but in the main code there is never a check to see which tool is desired to be used. So it just starts printing with T0, I dont know why Cura isnt injecting a tool request so that the machine switches to the correct nozzle. Every time I go about printing primarily on the second extruder there is always something that doesn't work quite right. I don't know what I am missing, the objects are selected on extruder 2, I disabled extruder 1 but that doesn't work either. Anyone familiar with dual extruders help is much appreciated! 

Edited by Erosion139
  • Link to post
    Share on other sites

    • Solution
    Posted · Dual Extruder, I want to print on the second extruder but the tool never gets called up

    Within the gcode file - does Cura add a call for T1 prior to your startup gcode?  It should be there, but then your StartUp Gcode is explicitly calling for T0.

     

    You could try changing that "T0" line in your StartUp Gcode to "T{initial_extruder_nr}" and see if it makes a difference.

  • Link to post
    Share on other sites

    Posted · Dual Extruder, I want to print on the second extruder but the tool never gets called up
    2 hours ago, GregValiant said:

    Within the gcode file - does Cura add a call for T1 prior to your startup gcode?  It should be there, but then your StartUp Gcode is explicitly calling for T0.

     

    You could try changing that "T0" line in your StartUp Gcode to "T{initial_extruder_nr}" and see if it makes a difference.

    I believe this was it! In Gcode that start command was replaced by T1, so Cura definitely adjusted the parameter accordingly! Thanks!

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...