Jump to content

Neither "Pause at Height" or "Filament Change" work on my Ender 3


johnnieq
Go to solution Solved by GregValiant,

Recommended Posts

Posted · Neither "Pause at Height" or "Filament Change" work on my Ender 3

As the title says, I cannot get "Pause at Height" or "Filament Change" to work on my Ender 3 v1.

 

"Filament Change" does nothing for me. :(

 

"Pause at Height" does nothing either, unless I modify the gcode and replace the M0 entries to M25. Then it will stop printing, and move the print head out of the way for only a few seconds. I have no time to change the filament. Is there a setting I am missing? Is there a gcode command that will make it pause a set amount of time? or one that requires an action from me to restart?

 

I haven't been able to find an answer anywhere.

 

My Printer is a Creality Ender 3. I believe it is a version 1. The motherboard says 4.2.2  and the chip is a STM32F103RCT6.

 

 

  • Link to post
    Share on other sites

    • Solution
    Posted · Neither "Pause at Height" or "Filament Change" work on my Ender 3

    When Creality first went to the 4.2.x mainboards they were OK.  Then they changed to the newer TFT type LCD displays.  The firmware of the display didn't play nice with the firmware of the mainboard.  As a consequence, no commands that send messages to the LCD work on those printers.  That includes M0, M1, M117, M600 and a couple of others.

     

    If you follow the link below there is a workaround that uses Search and Replace to add several gcode lines that can get M25 to work.

     

    Another workaround is to use the "Gcode after pause" box in Pause at Height to add "G4 S300" (where "S" is in seconds) to pause the print.  The down side is that G4 is a timed pause and if you make it too long, you can't shorten it.  If you make it too short then the print can resume in the middle of changing colors.  You also need to be standing there when the pause occurs.

     

    I'm attaching a gcode file that is a pausing test.  Open it in a text editor and you'll see that I've commented out a couple of different types of pause commands. 

    ;
    ;G4 S60
    ;M0
    ;M25
    M0 S60; Do the actual pause
    ;

    By adding or removing semi-colons from the front of the lines maybe you will find something that works.

    There are no heating commands or extrusions in the file.  The nozzle just runs around at a height of 10mm and then is supposed to pause.

    There is a more involved workaround in THIS THREAD.

     

    GV Pause Test.gcode

     

     

    • Like 2
    Link to post
    Share on other sites

    Posted · Neither "Pause at Height" or "Filament Change" work on my Ender 3

    GregValiant

     

    Your 1st suggestion to try using the "Gcode after pause" box in Pause at Height worked fine. I never had to go any further to try the others.

     

    Thanks! 

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...