Jump to content

Cura (4.12.1) doesn't set bed temperature in gcode (M140) when it's set to 0 degrees, which causes some printers to use their default temperature instead


AlteriusOmega

Recommended Posts

Posted · Cura (4.12.1) doesn't set bed temperature in gcode (M140) when it's set to 0 degrees, which causes some printers to use their default temperature instead

When slicing a model with the bed (build plate) temperature set to 0 degrees, Cura 4.12.1 doesn't actually set the temperature at all in the gcode. The M140 S0 line at the start is just completely missing though it is there at the end to turn the bed off. In my case with a CR-10S running Marlin firmware, the behavior is that my printer sets the bed temperature to 70 degrees instead. As you can see in the attached screenshot of the generated gcode, the lines for setting the hotend temp are there but no lines setting the bed. If I change it to 1 degree in Cura this is not the case.

 

Regardless of temperature chosen, Cura should always add the M140 line at the start to set the bed temperature so there is no ambiguity.

Cura 4.12.1 not setting bed temperature when 0 degrees.PNG

  • Link to post
    Share on other sites

    Posted · Cura (4.12.1) doesn't set bed temperature in gcode (M140) when it's set to 0 degrees, which causes some printers to use their default temperature instead

    Hey @AlteriusOmega,

     

    Are you sure you are on Cura 4.12.1?
    That version is from October 2022.
    There have been a lot of improvements made since that release. 

     

    We have a number of settings that "turn off" when you set the value to 0.
    There are a lot of cases where that's beneficial because "cool" often means room temperature, and that varies depending on your country and the season. I wouldn't be surprised if that's also the case for this setting. It's unfortunate your printer interprets that as 70 degrees, other firmware versions chose to ignore it.

    Is setting the value to 1 instead, a better solution in your case?
    Or should matching your room temperature be a better solution?

    Hope this helps 👍

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Like
        • 2 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...