Jump to content

Updating a gcode file (G29) and recording it as a gcode one as well ?


Domi1958
Go to solution Solved by rburema,

Recommended Posts

Posted · Updating a gcode file (G29) and recording it as a gcode one as well ?
  • I have to include a G29 line to my gcode in order to avoid touching the bed each time with too much effort (close to break something).
    But the file I created can't be save in 'gcode' mode, but just in docx.
    How can I have this G29 added while keeping the gcode operationnal for my printer.
    Many thanks,
    Dominique
  • Link to post
    Share on other sites

    • Solution
    Posted · Updating a gcode file (G29) and recording it as a gcode one as well ?

    If you continue with the manual solution, alter and save the file via notepad or notepad++ instead of word, then save it over the original file.

     

    Alternatively, you could also probably add a G29 either in a post-processing script (accessible from the plugins top bar menu in Cura), or even in the start gcode, in machine-settings (accessible via the printer/preferences).

  • Link to post
    Share on other sites

    Posted · Updating a gcode file (G29) and recording it as a gcode one as well ?

    CFFFP_Bouchon de banc de tour G29.gcode

     

    Sorry to come back with it; here I attached the Cura gcode which is causing me the trouble of 'strong touch' of the bed in all the cases.

    Just I added the G29 code earlier to check bed level before printing but this still not workable as the noze is forced in bed and I have to stop it in emergency.

    Could you check the first lines in order to check my own.

    Many thanks,

    Dominique

  • Link to post
    Share on other sites

    Posted · Updating a gcode file (G29) and recording it as a gcode one as well ?

    Hi @Domi1958

    I think what @obewan saw was this from your gcode file.

    M82 ;absolute extrusion mode
    G29 ; auto-level
    G28 ;Home
    G1 Z15.0 F6000

    You need to switch the G29 so it is below the G28.

    In Cura select "Settings / Printer / Manage Printer" and in the next dialog select "Machine Settings".

    On the left is the StartUp Gcode box.  You can edit the code in the box so it's like this:

    G28 ; Home
    G29 ; auto-level

    That way the printer will know where the nozzle is before it attempts to level.

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...