Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  

Cura closes after splash screen - solved

Recommended Posts


When i try to start cura ( tried it with version 14.01 till 13.10) i get the splash screen and after that it closes. only working version is 12.10...

the error in the output file is:

# Generating comtypes.gen._683BF642_E9CA_4124_BE43_67065B2FA653_0_1_0

# Generating comtypes.gen.TaskbarLib

Traceback (most recent call last):

File "C:\Program Files (x86)\Cura_14.01\python\lib\site-packages\wx-2.8-msw-unicode\wx\_core.py", line 14660, in <lambda>

lambda event: event.callable(*event.args, **event.kw) )

File "Cura\gui\splashScreen.py", line 16, in DoCallback


File "Cura\gui\app.py", line 75, in afterSplashCallback

from Cura.gui import mainWindow

File "Cura\gui\mainWindow.py", line 21, in <module>

from Cura.gui.tools import minecraftImport

File "Cura\gui\tools\minecraftImport.py", line 11, in <module>

from Cura.util.pymclevel import mclevel

File "Cura\util\pymclevel\__init__.py", line 4, in <module>

from indev import MCIndevLevel

File "Cura\util\pymclevel\indev.py", line 63, in <module>

from level import MCLevel

File "Cura\util\pymclevel\level.py", line 15, in <module>

from mclevelbase import ChunkMalformed, ChunkNotPresent, exhaust

File "Cura\util\pymclevel\mclevelbase.py", line 65, in <module>

appDataDir = win32_appdata()

File "Cura\util\pymclevel\mclevelbase.py", line 62, in win32_appdata

return os.environ['APPDATA'].decode(sys.getfilesystemencoding())

File "C:\Program Files (x86)\Cura_14.01\python\lib\os.py", line 423, in __getitem__

return self.data[key.upper()]

KeyError: 'APPDATA'


couldn't find it on google so i hope someone here can tell me what im doing wrong... I'm working on windows 7.





Share this post

Link to post
Share on other sites

Open a CMD window and type "set appdata" and see where your appdata actuall is. Is there something strange about it? I'm going to guess there are non english characters or it points to a network drive or something. Here is mine:


C:\Windows\system32>set appdata

Instead of where mine has "Otis" maybe yours has something like: François? Some non english character? That will mess up python sometimes (cura was written in python).


Share this post

Link to post
Share on other sites

When typing this command i got the error about the variabele not being defined. This is what i did (and it worked)

Start > Right click on this pc > property's > Advanced systemsettings > Environment variables > New

(im dutch so menu buttons may be different)

Then i added a variable with the name APPDATA and the value C:\Users\(My name)\AppData\Roaming

After that cura worked flawless



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Architect Design Contest | People
      The goal of this contest is to design a set of people figurines that could be used in such a project to make an area, office or mall seem populated. 
      Think of different types of people in different environments, like walking people, people standing still, working people, and both men and women.
      • 31 replies
    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!