Jump to content

Confusing Linux Error


WylieM

Recommended Posts

Posted (edited) · Confusing Linux Error

Hey guys, this is my first post here. I've been running Cura on my Chromebook (Through Linux, I just updated to the newest version) for over a year now, with no real issues. I've been doing the same thing to open Cura, enter "ls", selecting my Cura program that I've already given permissions for, and then opening it with the "./" typical command. I would like to add here that I am not a Linux expert at all, definitely a novice. I don't know entirely what is going on, but in the past I've been able to handle small problems. Anyways, the attached screenshot is the result that I've been getting every time I try to open Cura. In case it was a problem with Cura I downloaded the newest version and ran it. It went smoothly until I tried to open a file and clicked the folder icon. Then it crashed. This might be an entirely different and unrelated problem but I was able to open it, if that changes anything. I tried many different things but can't tell exactly what the solution is. If any more information is necessary I'd be happy to give it.

Thank you!

 

 

image.thumb.png.731dcddfd3257a26e344a4dbe038178c.png

 

Edited by WylieM
  • Link to post
    Share on other sites

    • WylieM changed the title to Confusing Linux Error
    Posted (edited) · Confusing Linux Error

    Running Linux on a Chromebook is more of a "Google wants you to be able to run Android Studio" thing than a "Google wants you to use this as a daily driver" thing so they're not too concerned about making changes which might break other things. I'm pretty sure the Linux development environment that gets installed on a Chromebook is based on Debian (or one of its children). If I'm wrong then these commands will do nothing (probably just give give you an error about not being able to find apt) so not really going to cause any harm (other than me having to do more research).

     

    First, the simple: just try downloading the appimage for another version of Cura (5.3.1 is a good choice) and see if that works. If not, some more advanced troubleshooting:

     

    Let's try reinstalling the package it seems to have a problem with (assuming it's installed in the first place, it might have had just libraries needed, in which case there should be no harm installing it)

    apt update

    sudo apt reinstall xcb

     

    That will fetch a list of the latest packages available, then reinstall the one that's causing the error. It sounds like it might be outside of the system's PATH environment variable, but I don't know, I don't use Linux on my Chromebook much. Anyway, try that, reboot, try Cura again. If that doesn't work, let's go for the kitchen sink approach. Run these commands:

    apt update

    sudo apt reinstall *xcb*

     

    That will (again) make sure we have the latest list of packages and then it will reinstall (or install if missing, which a lot of them might be) anything with "xcb" in its name. Reboot, run Cura again. See if it works.

     

    Whether or not it works, it'll probably leave you with stuff you don't need installed. Clean it up with this:

    sudo apt --purge autoremove

    That just uninstalls any packages you don't need (and deletes any configuration files they might have made and their downloads from the package cache). If the system is wrong about you not needing something and it breaks, just run sudo apt reinstall *xcb* again.

     

    Unfortunately if all that doesn't work... I'm out of ideas for now. I don't really have an equivalent setup to you (my Chromebook is arm64 so a lot of packages aren't available or need to be compiled from source, and on my desktop I'm rocking openSUSE Tumbleweed).

     

    P.S. You don't need to run ls before you run Cura. All that does is list files in the current directory. Just type ./Ultimaker and press tab (which should autocomplete the filename, or if you have more than one file that starts with that, keep pressing tab until it comes up with the right one).

    Edited by Slashee_the_Cow
    Added P.S.
    • Like 1
    Link to post
    Share on other sites

    Posted (edited) · Confusing Linux Error

    Thank you for your insight. I downloaded the newest Cura again, made it a file that I could open, and once again it crashed after i opened it. After it crashed i went to the terminal and saw the following message:

    image.thumb.png.5c48e22db7aa2665b6857344aed8e72f.png

     

    And so I tried the:

    apt update

    sudo apt install xcb

     

    multiple times, here is the result:

    Screenshot2023-09-0412_57_52PM.thumb.png.fc895cae6c3656d7f1a6e8fbe1d4ee65.png

     

    after that i tried to run both versions of cura. For the old one, still had the same core dumped message. For the new one, still crashed almost immediately. Next I tried the 

    apt update

    sudo apt reinstall *xcb*

     

    which opened up a long list, asked me if I could download some packages, which I replied "Y" to. At this point i was feeling optimistic, but after it took a while to download it said I had no space. I was planning on re sizing my disk and checking storage management, but decided to try my new cura one more time (It's 5.4.0 BTW). As usual it loaded, and I tried to open a file, it failed. I opened it one more time, but instead of pressing the folder icon I went to File > Open Recent and was actually able to load a file. It sliced and in theory I should be fine. I would prefer a permanent fix, but this temporary solution will have to do for now. Thanks again, I really appreciate your effort I wasn't expecting a response, I'm impressed. Thank you.

    Edited by WylieM
    accidentally saved early.
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...