Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
ediblepoly

Can't connect or install firmware through ReplicatorG

Recommended Posts

I have recently assembled my new Ultimaker, but cannot figure out how to update the firmware.

I have Netfabb and ReplicatorG. Using Netfabb, I can connect to my Ultimaker using COM3 and use the USB controls. The nozzle moves with the arrow keys and the platform works with the page up/down keys. The button to update the firmware is grayed out, but other than that, Netfabb seems to be working with my Ultimaker.

However, ReplicatorG has problems connecting to my Ultimaker and I cannot update the firmware through it. When I open up RepG I get a “New Firmware Available” message box. It says “a newer version (1.0) of the Ultimater - Arduino Mega Shield v1.5.X (Mega 2560 only) firmware is now available...Please select the right driver when changing from 5D to Marlin”. I click okay. Then another message says “Old firmware detected! Firmware version 0.1 detected; firmware version 1.0 required.”

I go to the menu Machine > Firmware Upgrade and choose “Ultimaker - Arduino Mega Shield v1.5.X (Mega 2560 only)”. Then on the next page I need to choose the firmware version to install. Of the four choices, I picked “Marlin 1.0.0 release candidate 1”. Then I pick COM3. Then finally I click the Upload button and it immediately says “Upload Failed: The firmware update did not succeed. Check the console for details...” This message comes up really fast as if it didn’t even try.

There doesn’t appear to be anything relevant in the console.

I tried this again with other cards and firmware version but get the same issue.

It seems like ReplicatorG is still not connected to the Ultimaker as all the buttons are grayed out except “GCode” and “Turn On”.

When I click Turn On this time it says “Connection error: Serial port 'COM3' already in use. Try quitting any programs that may be using it.” Nothing else is using COM3.

Any ideas on what I’m doing wrong?

Share this post


Link to post
Share on other sites
“Connection error: Serial port 'COM3' already in use. Try quitting any programs that may be using it.” Nothing else is using COM3.

Any ideas on what I’m doing wrong?

For this problem I close RepG.Unplug the USB to UM. Wait for a bit. Plug the USB back in and wait for a bit again and then start RepG again.

Not sure about the rest.

You can't have Netfab connected at the same time though either.

Share this post


Link to post
Share on other sites

If its still giving problems, try running replicatorG without attaching the USB and wait for replicatorG to say that it cant find a port to use. Then attach the USB, wait for the Arduino to get recognized and upgrade the firmware, or try upgrading using an older version of repG. Its a security lockout in 0034 to prevent repG from using older firmware (which can cause crashes when using 5D on repG 0034).

Share this post


Link to post
Share on other sites

Thanks for your help guys! I think its working now and I’ll try to print something soon.

I initially tried unplugging the USB, waiting, restarting RepG, etc. and couldn’t get it to work. I am using version 0034.

I downloaded the older RepG version 0024-r3 and ran it. With 0024, I was able to connect and control the machine. I updated the firmware (Marlin 1.0.0 release candidate 1) and it says it succeeded. Is this the firmware I should be using? I don’t know which is the best one.

If I connect now though the console says a lot of Unknown: garbage text. I can't seem to connect anymore in RepG 0024 now that the new firmware is installed. RepG 0024 seems hung up and I had to close it using the task manager.

I open RepG 0034. I changed the driver to Sprinter/Marlin. Then clicked turn on. The bar above is green and it seems to be connected. The controls work.

I'll post if I have any more issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!