Jump to content
UltiMaker Community of 3D Printing Experts

UM original Reset issue

Recommended Posts

Posted · UM original Reset issue

hey guys i've been working with the UM people for almost a year on my machine. i've gotten replacement parts for nearly everything but the main board and still no luck getting it working.

so i've got a couple of questions. what is the current firmware displayed on the machine with the latest CURA update?

what could be causing my machine to not stop at the preset temp when heating the head for a print?

should i be able to move the print head via the UMcontroller?

basically the problem i'm having is the printer will heat up to 220 then bounce between 220 and hotter temps until it resets no max temp error. or if there is it resets the moment it hits. setting the temp to 200 it seems like it tries to keep it at the right temp but it eventually gives a max temp error. i've also never seen the print head move.


  • Link to post
    Share on other sites

    Posted · UM original Reset issue

    Can you list the parts that were replaced?

    Has the Arduino Mega 2560 replaced (the board under the controller board)?

    I have a custom firmware on my so I can't tell you the version. Unfortunately, I don't think the version is ever incremented anyway. I think it will always say 13.11

    You should be able to move the print head via the Ulticontroller. I take it you can't? Under the Prepare menu, I think the last item (or nearly the last) is Move axis and you can use that to move them.

    Does that menu item not work for you?


  • Link to post
    Share on other sites

    Posted · UM original Reset issue

    yes they replaced the arduino first thing because it was dead out of the box.

    my UMcontroller shows 13.12.

    i cannot. i will set an increment for it to move and nothing will happen.


  • Link to post
    Share on other sites

    Posted · UM original Reset issue

    OK, my first thought was that the Arduino was bad. However, since that was swapped, I'm speculating about two things (no guarantees though just things for you to check).

    There is a 12V regulator on the control board (the top board) that feeds power to the Arduino. There is also a jumper on the board that determines if the 12V regulator powers the Arduino.

    So the two immediate thoughts are:

    - The regulator is bad or overheating

    - The jumper isn't in or isn't making good connection.

    Does the printer run without the USB plugged in? Does it execute moves? If so the jumper is probably OK. However if you need to plug the USB cable in that means the Arduino is pulling power from the USB cable and then the problem is that the USB power input has a 500ma resettable fuse which may trip depending on the load.

    I'd check the jumper since it's easy, If the controller is oriented such that the USB, poiwer and switch are on the top as if you just pushed the printer over from the right side, the jumper is at the bottom left and is labelled ARD_PWR. If you remove it, the printer MUST be connected to the USB so the Arduino is powered. Remove it and most likely the Ulticontroller will no longer show text. Place it back, jiggle it etc. See if the behavior changes.

    The next thing would be to check if the 12V output is good and you would need a voltmeter/multimetter to check, Do you have one? If so, with the board oriented as before, on the top left a little ways down there is a connector labelled 19V & LEDs. Measure that, it is the input voltage from the power supply. Then just below that on the left edge there are pads labelled 3.3V, 5V, GND (two pads) and then VIN. Measure the voltage from the GND pads to 3.3V, 5V and VIN which is the output of the 12V regulator so should be close to 12V

    If they check out, then the next thing is to eliminate as many sources of the problem as possible. I would recommend you do the following:

    Power off and unplug then disconnect all cables except the temp sensor, the X stepper and the electronics cooling fan (I mean all, endstops, steppers, hotend heater, fan etc). Label/mark and note the orientation of the drivers (usually done by noting if the adjustment screw is above or below the heatsink) and then carefully remove all stepper drivers except the X driver. Disconnect the Ultcontroller. Replace the cover so the fan is cooling parts (always do this after subsequent steps).

    Now see if you can get the X axis to move. Manually move it to the home position (front left). Connect the USB cable and the power supply and switch on. Start Cura and go to File->Preferences and change the printing window option to Pronterface. The go to File-> Print.

    On the left you will see something that looks like a target. It allows you to electronically move the head in .1, 1mm, 10mm or 100mm depending on which "ring" you click and moves in the direction labelled. Using the +X side, click the 1mm ring and see if the head moves.

    When testing, use the 1mm moves. Note that if you followed my instructions, you disconnected the endstops so don't go too far with moving the head electronically. If you do, the printer will make a horrible noise but is unlikely to be damaged.

    If X is working, power off and unplug. Place the Y driver back. NOTE: VERIFY THE ORIENTATION. IF YOU POWER THE PRINTER WITH THE DRIVER IN THE WRONG ORIENTATION, THE DRIVER WILL BURN UP. Then do the Z. NOTE THE ORIENTATION AGAIN. If X, Y and Z are working, place the extruder driver back in **** VERY IMPORTANT **** THE DRIVER WILL MOST LIKELY BE ORIENTED 180 degrees from those on the right. When you put the E driver back in place, test the X, Y and Z axes. You can't test the E driver until the hotend is heated about something like 170C

    Now reconnect all the endstops. recheck X,Y,Z.

    Power off and unplug. Now reconnect the hotend heater. Back in the printing window, use the temperature box to set the the temp to 180. Watch the graph and the temp in the window title and keep using the X, Y and Z to test that the printer is responding and not hung. If it hangs/stops responding unplug immediately. If it stabilizes at 180, use the top of E bar in the printing window to extrude 1mm of filament and check that the extruder is turning.

    Now put the temp up to 220. Watch the graph and the temp in the window title and keep using the X, Y and Z to test that the printer is responding and not hung.

    If it stabilizes at 220, power off and unplug and reconnect the fan. Retest at 220C. Watch the graph and the temp in the window title and keep using the X, Y and Z to test that the printer is responding and not hung.

    Finally, reconnect the Ulticontroller.

    Let us know what you find causes the first failure.


  • Link to post
    Share on other sites

    Posted · UM original Reset issue

    i pulled the jumper for the arduino power and now it lets me heat to set temp with no problems. i set it to print from sd and it reached print temp said heating done and the UMcontroller showed the x and y changing but the print head wasn't moving.

    i unplugged everything like you said above. went into CURA and could not get it to connect to the printer. there were no errors it went from opening serial port to connecting to closed. so i installed a custom firmware and was able to connect and control the extruder temp. but could not get any movement out of it. so i reconnected everything and popped the internal breaker in the power supply. for now i'm just going to set it aside till i don't feel like throwing it out the window...

    any ideas on why the motors don't work?


  • Link to post
    Share on other sites

    Posted · UM original Reset issue

    So the printer partially runs without the jumper? Or did you replace the jumper and get the hotend to heat? Are you sure the hotend was heated?

    If the PS is shutting down, it indicates that either it is bad or there is a short or partial short in the board.

    You will need a voltmeter to check the points I mentioned.

    Was the PS replaced?


    The UM1 runs on two voltages basically the stepper/heater voltage from the power connector and the logic voltage. The logic voltage comes from the 12V regulator which is supplied from the power connector and the 12V then goes to the Arduino (when the jumper is in) which then regulates it down to 5V (and 3.3V). The 5V is sent back up to the UM1 shield and is used for the Ulticontroller and the logic side of the stepper drivers. When you remove the jumper and plug in the USB cable the Arduino uses the 5V from the USB cable to run and still sends it back up to the shield.

    So if the Ulticontroller is working without the jumper but the motors aren't stepping then it implies the supply voltage is insufficient.

    The confusing part is the heater is run off the supply voltage too. How long does it take the heater to reach the set temp?

    It's possible that one or more of the stepper drivers are bad and when enabled, they draw too much current cause the PS to shutdown or the supply voltage to dip. It's possible that it could dip enough that path to the Arduino 5V power goes too low for the Arduino to get enough voltage on the 5V regulator to remain running.

    There are a few other things that run off the supply voltage. Namely the fan that cools the electronics and the fan on the print head. You should observe those, particularly the electronics cooling fan as it is directly connected to the supply voltage to see if it is slowing down when you attempt to electronically move the head

    There are also capacitors across the supply line that might be shorting or possibly shorting the supply. However, usually when a capacitor fails, it fails either completely open or shorted.


    The thermocouple amp on the top of the print head which is critical to measuring the temp requires a clean 5V. If you saw wild swings while heating with the printer self powered (jumper in), it indicates that the voltage path from the supply connector to the 12V regulator to the Arduino's 5V regulator is unstable causing the 5V line to be unstable resulting in what looks to be wild temp swings.

    This would also explain the random reboots.

    This is more evidence of problems with the primary power system. The fact that you had the PS shutdown means it is either weak or being overtaxed by something. The primary current sinks are the heater and the steppers.


    Just timed how long my printer takes to go from room temp to 210C - about 105 seconds. Is yours about the same?


  • Link to post
    Share on other sites

    Posted · UM original Reset issue

    so i checked the voltages and got 3.3 on the 3.3, 3.81 on the 5, and 3.36 on VIN. it also seems like one of my steppers shorted when the safety on the power supply popped. if i plug it in the UMcontroller screen dims and just on usb power it gets hot to the touch. i have the dual extruder so i just removed the bad one and swapped the second extruder stepper into that slot.


  • Link to post
    Share on other sites

    Posted · UM original Reset issue

    Is it working now?


  • Link to post
    Share on other sites

    Posted · UM original Reset issue

    still no movement from the x and y axis. the z axis however twitches if i try to move it. it basically moves forward then back to the original position half the time.


  • Link to post
    Share on other sites

    Posted · UM original Reset issue

    Measure those voltages again. Ideally with the cover on and while you are trying to move the axes.


  • Link to post
    Share on other sites

    Posted · UM original Reset issue

    the voltages read correctly with the jumper in place. and as i stated above when its off.


  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • Here it is. The new UltiMaker S7
        The UltiMaker S7 is built on the success of the UltiMaker S5 and its design decisions were heavily based on feedback from customers.
        So what’s new?
        The obvious change is the S7’s height. It now includes an integrated Air Manager. This filters the exhaust air of every print and also improves build temperature stability. To further enclose the build chamber the S7 only has one magnetically latched door.
        The build stack has also been completely redesigned. A PEI-coated flexible steel build plate makes a big difference to productivity. Not only do you not need tools to pop a printed part off. But we also don’t recommend using or adhesion structures for UltiMaker materials (except PC, because...it’s PC). Along with that, 4 pins and 25 magnets make it easy to replace the flex plate perfectly – even with one hand.
        The re-engineered print head has an inductive sensor which reduces noise when probing the build plate. This effectively makes it much harder to not achieve a perfect first layer, improving overall print success. We also reversed the front fan direction (fewer plastic hairs, less maintenance), made the print core door magnets stronger, and add a sensor that helps avoid flooding.

        The UltiMaker S7 also includes quality of life improvements:
        Reliable bed tilt compensation (no more thumbscrews) 2.4 and 5 GHz Wi-Fi A 1080p camera (mounted higher for a better view) Compatibility with 280+ Marketplace materials Compatibility with S5 project files (no reslicing needed) And a whole lot more  
        Curious to see the S7 in action?
        We’re hosting a free tech demo on February 7.
        It will be live and you can ask any questions to our CTO, Miguel Calvo.
        Register here for the Webinar
          • Like
        • 11 replies
      • UltiMaker Cura 5.3.0-Alpha 🎄 Tree Support Spotlight 🎄
        Are you a fan of tree support, but dislike the removal process and the amount of filament it uses? Then we would like to invite you to try this special release of UltiMaker Cura. Brought to you by our special community contributor @thomasrahm
        We generated a special version of Cura 5.2 called 5.3.0 Alpha + Xmas. The only changes we introduced compared to UltiMaker Cura 5.2.1 are those which are needed for the new supports. So keep in mind, this is not a sneak peek for Cura 5.3 (there are some really cool new features coming up) but a spotlight release highlighting this new version of tree supports.  
          • Like
        • 17 replies
      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    • Create New...