Jump to content
Sign in to follow this  
pronus

Issues with bed size with Cura

Recommended Posts

Posted · Issues with bed size with Cura

I first off would like to mention that I don't have an Ultimaker but I LOVE the Cura software. This is my first 3d printer (Makerfarm Prusa I3) and everything is working great with Cura except for my bed size.

I'm not able to get use out of the entire bed. On the left side (X axis maximum) the printer will actually crash into the X motor assembly if I try and use the maximum (left side of the bed) X axis in cura. If I use the X axis minimum (right side of the bed) in Cura, I end up about 20mm short from the edge of the glass on the right side of the bed.

It's only 20mm, so I have been just dealing with it for now, but now my projects are requiring that I use almost every mm I can on the bed and I also don't want to run the risk of the x carriage smashing into the x motor assembly.

I am sure there is a way to adjust this in the Cura software to shift everything over 20mm, but I have yet to figure it out. I attempted to just offset my X endstop 20mm, but my extruder gear would bash into the X idler before the endstop would contact.

Any helps would be much appreciated.

 

Share this post


Link to post
Share on other sites
Posted · Issues with bed size with Cura

Have you gone into Machine -> Machine settings and then adjusted all the measurements to match your printer?

 

Share this post


Link to post
Share on other sites
Posted · Issues with bed size with Cura

Yes, it was one of the first things I did including changing some of the other settings that others Makerfarm users had done to get Cura up and running for them.

I thought about just increasing the bed size in Cura larger than my actual bed and trying to figure out/ eyeball the areas where my bed actually ends, but I decided not to due to the risk of smashing my x carriage. I also don't think it would get me more X Axis Minimum space.

You got me thinking though, I just noticed from my last print that there is same kind of issue in Pronterface once I imported the Cura Gcode. The last thing I printed showed that it was right on the edge of the bed in Pronterface, but it was off by 20mm.

I am starting to think it may not be the Cura software is is possible my firmware or Pronterface.

 

Share this post


Link to post
Share on other sites
Posted · Issues with bed size with Cura

What you could do, is change your homing procedure.

Right now it says:

G28 X0 Y0

If you modify that to:

G28 X0

G92 X-20

Then everything will shift 20mm to the right. So you will avoid smashing into the left side.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 98 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!