Jump to content
Ultimaker Community of 3D Printing Experts
teocreo

Meccanica finita,ora come procedo ??

Recommended Posts

Salve a tutti,oggi,dopo una marea di tempo sono riuscito a finire la parte meccanica della mia ultimaker,tutt'ora devo ancora dare corrente per la prima volta,devo ancora settare i driver per gli stepper e via così,ho,come da titolo,soltanto finito tutta la meccanica ed i vari cablaggi...

vi allego il link riguardante la scheda che ho montato,

http://www.ebay.it/itm/PCB-Ultimaker-1-5-7-scheda-di-controllo-stampante-3D-compatibili-con-le-rampe-/121411205414?pt=Altro_per_la_Casa&var=&hash=item1c44abf926

i motori sono da 1.7A

unica modifica che ho fatto,a livello di meccanica è quella riguardo la vite che alza ed abbassa il piano,ho montato una barra filettata M12x1.75 di passo

vorrei possiilmente sapere ora come devo procedere,perchè in internet si trovano molti consigli e spesso in contrasto tra loro...ad esempio,per settare i driver alcuni dicono con tensione,altri no,altri con i motori scollegati altri collegati,alcuni con cacciavite in plastica altri normalissimo cacciavite in metallo(non capisco il motivo)

Si insomma,se potreste accompagnarmi alla prima accensione di questa stampante 3d..

Chiedo gia umilmente scusa in quanto per me è la prima volta in questo affascinante monto della stampa 3d.

un saluto e grazie a tutti voi in anticipo :smile:

 

Share this post


Link to post
Share on other sites

Purtroppo io non ho una Ultimaker Original e non mi permetto di dare consigli per sentito dire :(

L'unica cosa che ti posso consigliare e di scrivere un Thread nella sezione http://umforum.ultimaker.com/index.php?/forum/26-assembly/ in inglese. Infatti ho segnalato la tua richiesta anche in un gruppo italiano ultimaker ma nessuno si è fatto avanti, ma gli italiani sono così prendono molto e danno molto poco -_-

Mi dispiace

Paolo

 

Share this post


Link to post
Share on other sites

ciao,ho provato e cercato ho scoperto cura,ma ho dei problemi,non riesco a connetermi ad arduino,e quando ci riesco,va a buon fine sono l'hupgrade del firmware,ma il resto non va,non riesco a caricare o fare altro,non va nemmeno il display,nulla,non capisco dove puo essere il problema...

consigli ??

 

Share this post


Link to post
Share on other sites

Ciao Teocreo,

se segui la guida di Gr5, subito dopo il post dei link di Daid, poi andare tranquillo.

 

Here are my instructions for building Marlin - I've only tried them with the UMO firmware. There are tons of options you can mess with in Configuration.h and this file is very well documented and very easy to edit.

 

GUI METHOD

 

There are instructions that come with the erik zalm download (and probably all firmware versions) in the "README.md" text file.

Basically you download and install arduino ide:

http://arduino.cc/en/main/software

Then copy the sanguino software as explained in README file. Open Marlin.ino file in Arduino IDE by double clicking it (not pde file as stated in README - I think that's old). Select board as "Mega 2560" as explained in README file (white UM2 likely uses a different computer chip). Go to "file" "preferences" and select "verbose output" so you can find your hex file. Then build it by clicking the check box in the upper left corner. At the bottom you will see it compiling Marlin. At the end of this it says where the hex file is. If you are currently connected to your UM through USB you can just click "file" "upload" and you are done! But you should locate that hex file and save it somewhere along with the Configuration.h file used to create it so you can recreate the same version with maybe one change. Also you can upload the hex file using Cura in expert menu.

 

COMMAND LINE METHOD

Alternatively you can build Marlin with somewhat more detailed step by step instructions the command line way (which I don't prefer):

http://www.extrudabl...n-from-scratch/

 

Share this post


Link to post
Share on other sites

Non so come ringraziarti,molto gentile...ho notato che fin'ora tutte le prove che ho fatto,sul display non si è mai visto nulla,è una cosa da sistemare dopo oppure ho un "bivio" ora e se continuo così,poi per far andare il display (e la sd) devo rifare tutto da capo ??

ciao e grazie ancora

 

Share this post


Link to post
Share on other sites

ho provato,ma non riesco a caricare tutto,nel senso che quando carico ,le "sbarrette" verdi arrivano quasi fino in fondo ma mancano le ultime due,e rimane li fermo.....non fa piu nulla per un bel po...

che puo essere ??

insomma,tutto il lavoraccio per farla,pensavo che bastava poi caricare aruino con le varie impostazioni della macchina ed invece..

 

Share this post


Link to post
Share on other sites

Ciao,ancora non va...la cosa che mi vien da chiedermi è:

ma se con Cura non riesco a fare nulla,perchè,anche leggendo un po in giro ,altre persona hanno avuto problemi di connessioni,come mai "infilandoci" dentro il programmino tramite il programma di arduino e poi montando la scheda su arduino stesso non va nulla ??

come mai fin'ora sul display non riesco a visualizzare nulla ???

non ci sto capendo nulla,ho provato anche con altre versioni di cura,ma nulla,niente da fare,e arduino va,perchè mi carica i programmi di esempio,vedi blnk,ma carica anche quello dell'ultimaker.....

non so proprio che fare..

 

Share this post


Link to post
Share on other sites

Ciao Teocreo,

il problema relativo allo schermo potrebbe essere dovuto ad una errata configurazione del firmware...che schermo hai montato ? Che problemi ti da ? Sei riuscito a far muovere la macchina con cura o altri programmi ? Tu non avendo montato l' elettronica originale ultimaker potresti avere qualche problema in più nella configurazione del firmware e difficilmente funzionerà con quello di default...

 

Share this post


Link to post
Share on other sites

forse a me sfugge una cosa....

ma la scheda principale non è praticamente una sketc da applicare su arduino ??

in pratica non è altro che una scehda che interfaccia i pin di arduino verso i pin dei vari componenti della stampante...che dovrebbe cambiare da una all'altra,non ci sono ne integrati,ne altro,soltanto i finali per la resistenza dell'estrusore...

poi,come si fa a configrare il firmware che cura lo sbatte dentro direttamente ??

forse è proprio questo passaggio che mi sfugge...

il display che ho montato è uguale a quello di questa inserzione ebay 201091818122

questa la scheda che ho montato http://www.ebay.it/i...=item1c44abf926

non capisco,forse sbaglio qualcosa...

pensavo che una volta fatta la meccanica,bastava caricare su arduino il "programma" che "accetta" i file prodotti dall software che converte i disegni 3D in layer e Gcode....

ma evidentemente mi sbagliavo...

mi puoi aiutare ad uscirne da sto problema ??

 

Share this post


Link to post
Share on other sites

Questo è il tipico esempio della natura di puro marketing dell' open hardware. Se non si prende il kit di montaggio originale, si finisce in questo modo e, alla fine, si rischia di spendere di più per costruire la macchina. Hai provato a chiedere aiuto in forum di veri smanettoni, tipo quelli RepRap? ad esempio http://forums.reprap.org/index.php?349

Buona giornata

Paolo

 

Share this post


Link to post
Share on other sites

forse a me sfugge una cosa....

ma la scheda principale non è praticamente una sketc da applicare su arduino ??

 

Non entro nel merito del tuo problema specifico poiché ho una UM2 e non ho mai messo mano su una UMO, però ... lavoro con schede elettroniche, MCU, Arduino, ecc. e posso dirti che, ovviamente, il firmware è tagliato su misura sull'hardware, quindi, se cambi qualche pezzo (... e non solo la scheda principale, ma qualunque pezzo) con qualche cosa che NON è al 100% compatibile (... piedinature, tensioni, assorbimenti, valore dei segnali, firmware che ha a bordo, ecc.) ... puoi stare sicuro che vai incontro a problemi.

Il FW che installa Cura è fatto esattamente per un determinato HW ... o monti un HW al 100% identico o non ti puoi aspettare che vada. Quindi ... prima di tutto devi verificare che tutto quello che hai montato, dalla scheda principale ai driver per i motori ed al display, sia al 100% compatibile con quanto iil FW si aspetta.

Se SI, allora riverifica il cablaggio e, se ne hai dovute fare, le eventuali saldature ... perché DEVE funzionare.

Se NO, allora ... ho compri l'HW che il FW si aspetta, o metti le mani al sorgente del FW, lo personalizzi per l'HW diverso e lo ricompili.

Non ci sono altre scelte ...

Guglielmo

 

Share this post


Link to post
Share on other sites

sono pienamente d'accordo con te,ho un'altra domanda da fare però....

ho dato un'occhiata al firmware da infilare dentro arduino,tramite il programma di arduino stesso,ed ho visto che ci sono una miriade di impostazioni,queste cura le setta in base al setup della macchina e secondo le specifiche principali della macchina stessa ??

chiedo perchè volevo sapere se arduino riceve tutto tramite cura e direttamente da cura oppure ci sono altri passaggi da fare che magari salto..

vi ringrazio moltissimo per l'aiuto che mi state dando,se avete consigli ...son qua...

 

Share this post


Link to post
Share on other sites

Allora il procedimento è questo a grandi linee:

visto che non hai un hardware identico al kit ufficiale Ultimaker NON puoi utilizzare Cura per caricare il firmware ma devi crearne tu una versione customizzata su ciò che hai come componenti. Per fare questo ci sono due strade o parti da una versione generica e metti mano a tutti i parametri o usi un builder che ti setta i parametri fondamentali per poterla muovere marlinbuilder.robotfuzz.com.Prova con il builder e se hai fortuna funziona tutto e sei a posto sennò con l' ide di arduino devi customizzare i parametri che non hai potuto cambiare col builder. Una volta creato il firmware lo devi caricare con Cura andando in machine-install custom firmware. Visto che hai preso il mega monta quello che almeno verso il pc sei abbastanza sicuro che con i driver non hai problemi. Se lo schermo continua a non andare devi modificare i parametri individuando il nome esatto che di solito è scritto sulla scheda e andando ad abilitarlo nel file di configurazione. Se hai anche il lettore SD ricorda di abilitarlo nel builder.

 

Share this post


Link to post
Share on other sites

devo dire che come sempre la fortuna mi assiste....

il venditore mi ha rosposto dicendomi che in pratica i pin non sono uguali all'originale(come voi avevate previsto) e che lui,fosse stato in me,come prima stampante 3d non avrebbe acquistato questa scheda...

MA PORCA PALETTA !!! perchè ha scritto ultimaker 1.5.7 se non è così ??

erche almeno non ha scritto che i pin non sono uguali all'originale ?? perchè in quel aso un'idiota come me non l'avrebbe acquistata !!

ora come faccio ad uscire da questa bellissima situazione ??

a un'altra domanda mi sorge spntanea...ma gli altri utenti che l'hanno acquistata come hanno fatto a farla andare ??

mah,ora aspetto qualche file dal venditore,o il file per arduino,o la mappa dei piedini,anche se a sto punto faccio prima a ricavarmela da solo,ma poi,una volta che so che il piedino 33 di arduino va al segnale della sonda...poi con tutte queste informazioni,come faccio a modificare il firmware per far funzionare le cose ????

mi sembra impossibile che a me succedano sempre ste cose....

 

Share this post


Link to post
Share on other sites

il venditore mi ha risposto dicendomi che praticamente la piedinatura non è ugale alla versione originale...

ma allora perchè non l'ha scritto o almeno non ha postato il file fìda scaricare (come hanno fatto altri venditori) ??

beh,ormai queste ho e queste dovranno adare,non penso che tutti quelli che le hanno acquistate le abbiano buttate via

in ogni caso ,se mi armo di santa pazienza e con il tester verifico dove sono realmente collegati tutti i pin della scheda,poi sarebbe possibile rimappare marlin ??

ho visto che c'è una sezione dedicata alle varie schede,dove c'è proprio una pagina per definire i pin...

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!