Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
redsalamander

Build plate objects arangement

Recommended Posts

Has anyone else noticed that in Cura slicer that some machine don't allow you to move objects around on the build plate.

I think its related to the graphics card or driver, as I had a laptop with a ATI graphics card that got damaged and I swapped the HDD to a laptop with Intel graphics. I could move objects before and not it wont allow me. I have a couple of other machine with Intel graphics and they all seem to have the problem.I thought it was just something like an arb version of .net and never thought much about it till I moved the Hdd and the installation is 100% the sameas it was its just different HW of which most notibly the change was the Graphics card.

It occured to me that some people may not even know theyre missing it as they may never have used it

 

Share this post


Link to post
Share on other sites

Latest drivers on all of them no colour correction but will check to confirm. ( may be on the one with ati but its unlikely that it is)

The one that was working before the laptop expired had ATI in and the catalyst contorl center is still install but I cant get it it without an ATI card so cant fully remove it. will go looking for an uninstaller.

I also have a couple on VM's will maybe try with one of them, but slicing like that may be agony.

Im going to put another Hdd in the one machine do a fresh install and see if its different

 

Share this post


Link to post
Share on other sites

Well, the selection and dragging of objects in Cura works by drawing the 3D model in a single solid color, grabbing the pixel color under the mouse, and checking of that is a pixel that corresponds to a color chosen for the model.

This all happens before the actual screen is drawn and refresh, so you normally never see this.

One of the things that can cause problems here is 16bit colors, and possibly color correction (I know for sure 16bit colors cause issues. But who does that these days?)

 

Share this post


Link to post
Share on other sites

in my case I can see the selected model is lighter and drag that around the build plate. It not however allowing me to select any other parts so I cant move them. What I end up doing is pushing them with the part I can select off the build plate so they dont print. and then deleting the active part reverts the selection to the next part loaded.

It does that for stal files that where split into parts and if I load 2 parts seperately.

 

Share this post


Link to post
Share on other sites

Last night I started from the beginning and tried to work through everything. I tried reinstalling Pyton as I get an error every time I exit but that wasnt it. ( I beleive its Freecad related but not what Im fixing now)

I noticed that when I switch to overhang view I get an openGL error so re-looked at the drivers

The laptop's ATI graphics the latest drivers by the manufacturer loaded. I downloaded the lastes ATI CCC and installed that and behold the openGL error is gone and I can select objects again.

Im moving on to the seccond machine this morning to see if I can find a similar result but Intel graphics are proving a little harder to find stock drivers for.

 

Share this post


Link to post
Share on other sites

Is there a way to resolve that conflict with Freecad?

Also result on the other machine with Intel graphics and yet still relater to ATI Drivers. /the machine the drive came from had an ATI card and CCC stays on even if you don't have an ATI card in anymore.

I found and ran the ATI Catalyst Removal Tool it removed it all and after that the Intel driver detector actually identified the card and allowed the correct drivers to download and install. Result is it works as it should.

I'm loading the CCC on the 3rd machine ( has ATI Card ) to see if the resolution replicates there, but it's looking good.

the 4th machine a atom netbook hasn't had anything ATI near it and is 32 bit Win7 so not sure anything I've done here applies but I canlive with 3/4 machine working as it should.

 

Share this post


Link to post
Share on other sites

Last piece of the puzzle the Atom Netbook. (the CCC fixed the other machine as expected )

The Atom Machine doesn't have andything ATI in but the OpenGL error seems to be related.

If you go into the Intel Graphics Media Accelerator Driver there is a button for 3D settings. (the flat 3D not our kind, printer humor :-) ) that opens an OpenGl settings window with a list of options. Under "Depth Buffer Bit Depth" change it from 16Bit to 24Bit Depth Buffer. Close and open Cura and test if its working. That worked in my case.

Thanks Daid for the 16bit colour hint its immediately drew my attention when I saw this and thought it maybe related.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Terms of Use Privacy Policy