Jump to content
Ultimaker Community of 3D Printing Experts

Stan-D

Member
  • Content Count

    15
  • Joined

  • Last visited

Community Reputation

1 Neutral

Personal Information

  • Field of Work
    Other
  • Country
    DE

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Stan-D

    IR-Sensor für ABL am Ultimainboard

    OK, da hier so viel Resonanz gekommen ist... Habe etwas experimentiert und es weitgehend hinbekommen. Ja, es ist möglich den IR-Sensor am Ultimaker ( Ultimainboard 2.1.4 ) zu betreiben und ohne Löt- und Umbauarbeiten! Einfach einen freien digitalen Port mit der Sensorleitung verbinden und los gehts... Einzig die Firmware muss für die Endstops angepasst werden. Sofern Interessenten für Softwarefeintuning vorhanden sind, gerne melden
  2. Stan-D

    Ultimaker 2 x y Switch broken Problem

    Du hast zu Anfang geschrieben, dass der X-Motor sich nicht bewegt hat. Kann es sein dass der X-Motor defekt ist bzw. ein Kurzschluss an der Verkabelung des Motors vorliegt? Evtl. mal versuchen den gegen den Feedermotor zu wechseln. Ist schon alles etwas seltsam - erst Netzteil und dann alles nacheinander...
  3. Stan-D

    Ultimaker 2 x y Switch broken Problem

    Hast du den Durchgang der Kabel durchgemessen? Normal solltest du Durchgang an beiden Enden haben, wenn du die Schalter betätigst. Hast du vlt. die Anschlüsse an den Schaltern vertauscht? So dass NC anstatt NO vorliegt? Dann kann da Board nicht mit der Logik um. Widerstandsmessung am Stecker Board gezogen machen, Endschalter nicht betätigt, dann kein Durchgang. Wenn Endschalter betätigt wird, dann Durchgang = 0 Ohm! Wenn andersherum, dann sind die Anschlüsse am Endschalter vertauscht ( NO und NC ).
  4. Stan-D

    Ultimaker 2 x y Switch broken Problem

    Ein kleiner Tip zur Problemsuche: Wenn alle Achsen gleichzeitig "Homen", kennst du nicht die Achse, welcher Fehlerbehaftet ist! Am besten Repetier-Host oder ähnliches Programm installieren, wo du über USB-Verbindung einzelne Achsen "Homen" kannst. Wenn der Fehler bei X und bei Y Achse auftritt, hast du die Endschalter ggf. verwechselt. Wenn es eine Einzelne Achse ist, die nicht abschaltet, dann ist ein Kabelbruch vorhanden, oder der Schalter wird nicht richtig betätigt. Du schreibst, dass du die Schalter gewechselt hast! Waren das nur Schalter oder komplett mit Verkabelung? Meistens ist die Verkabelung sehr empfindlich und zwar im Bereich der Stecker am Board und am Schalter direkt!
  5. Hat jemand schon den IR-Sensor von David Crocker am Ultimainboard 2.1.4 angeklemmt bekommen bzw. ABL mi Marlin 1.1.9 oder jünger zum laufen gebracht? Bin jetzt am überlegen, wie ich es am Besten bewerkstelligen soll... Variante 1: Transistor an die Signalleitung klemmen, der an den Anschluss Z-Switch kommt, Z-Min und Z-Max wechseln. Variante 2: Über einen der freien Pins am Board codieren und Firmware anpassen.
  6. Stan-D

    Servo an J26 Ultimainboard Marlin 1.1.9

    Hab da endlich eine Anleitung für die Einstellung der Firmware gefunden: https://www.thingiverse.com/thing:2777682 Mal schauen ob die Platine des UM das mitmacht, bzw. die Pinbelegung bei Github richtig hinterlegt sind. Ich hab mir diese Variante des Druckkopfes anfertigen lassen, nur mit einem Alu-Nocken http://www.khwelling.nl/3d.um2_corexy.php Umschaltung soll mit dem Servo erfolgen, um möglichst keine unnütze Belastung auf die Riemen zu geben. Und anschließend mit dem Z-Offset beider Düsen die Längendifferenz der einzelnen Düsen aus der Produktion ausgleichen zu können.
  7. Stan-D

    Servo an J26 Ultimainboard Marlin 1.1.9

    Danke für die Antwort! Hatte heute Morgen das Problem bereits gefunden. SERVO0_PIN 13 ist richtig, zumindest läuft die Arduino IDE dann durch. Ob die Ansteuerung damit geht, habe ich noch nicht ausprobiert... Wie bereits erwähnt, habe ich gerade mal ca. 15 Stunden Berührungszeit mit der Programmierung. Überwiegende Zeit war mit den fehlenden Librarys in der IDE verschwendet. Wenn ich es richtig verstanden habe, dann sind nur die Winkel über Werkzeug- bzw. Extruderwechsel definiert. PWM-Range entsprechend der Servorichtung bereits als Beispiel vorgelegt. Und schließlich die Ansteuerungszeit in ms für die Dauer der Bewegung. Marlin 1.1.9 habe ich auf den Drucker geladen. Originale Menüführung ist gegenüber deinen Versionen ein reinster Krampf! Momentan läuft der kleine Lüfter aber nicht mehr beim Aufheizen über 50°C .
  8. Hallo an alle, ich bin aktuell mit Marlin 1.1.9 am experimentieren und würde gerne einen Servo über den Anschluss J26 ansteuern, der eine "Switching Nozzle" betätigt. Komme aber mit der Konfiguration nicht weiter. Hat hier jemand mit der Servoansteuerung und Pinbelegung Erfahrung? Mit der Programmiersprache bin ich nicht so sehr vertraut, versuche mir jetzt etwas anzueignen... Folgender Fehlermeldung bekomme ich in der ArduinoIDE: Arduino: 1.8.7 (Mac OS X), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)" sketch/Marlin_main.cpp: In function 'void move_nozzle_servo(uint8_t)': Marlin_main.cpp:12132:53: error: 'MOVE_SERVO' was not declared in this scope MOVE_SERVO(SWITCHING_NOZZLE_SERVO_NR, angles[90]); ^ exit status 1 'MOVE_SERVO' was not declared in this scope In Configuration.h // A dual-nozzle that uses a servomotor to raise/lower one of the nozzles #define SWITCHING_NOZZLE #if ENABLED(SWITCHING_NOZZLE) #define SWITCHING_NOZZLE_SERVO_NR 0 #define SWITCHING_NOZZLE_SERVO_ANGLES { 0, 90 } // Angles for E0, E1 #define HOTEND_OFFSET_Z { 0.0, 0.0 } #endif #define NUM_SERVOS 1 // Servo index starts with 0 for M280 command // Delay (in milliseconds) before the next move will start, to give the servo time to reach its target angle. // 300ms is a good value but you can try less delay. // If the servo can't reach the requested position, increase it. #define SERVO_DELAY { 300 } // Only power servos during movement, otherwise leave off to prevent jitter #define DEACTIVATE_SERVOS_AFTER_MOVE --------------------------- pins_ULTIMAIN_2.h #define SERVO0_PWM_PIN 13
  9. Stan-D

    Feeder Motor spinnt (Board?)

    Hi, meine Vermutung ist, dass du einen Kabelbruch bzw. Wackelkontakt an einer der vier Leitungen am Motor oder Stecker hast. Würde mal damit anfangen... Wie die Vorredner bereits geschrieben haben, evtl. die Steppermotoren gegeneinander Tauschen. Platine als aller letztes in Betracht ziehen, aufgrund der Kosten. Viel erfolg, hatte das auch schon mal direkt am Stecker - fällt erst nicht direkt auf.
  10. Stan-D

    Ultimaker 2 Dual Extruder einstellen.

    Hallo, ich wollte mal nachfragen, in wie weit dieses Projekt noch läuft? Auf der Homepage von Marin ist der Umbausatz nicht mehr zu erreichen... ...bzw. die Verlinkung nicht mehr gültig. Weiterhin sind die Definitionen für die Düsen nicht mehr korrekt, so dass mit Curry 3.4.1 nichts mehr geht. Ich habe diese etwas angepasst, so dass keine Fehlermeldung mehr auftaucht und ein Dualbetrieb zu gehen scheint. So sehen die Modifikationen der Variants bei mir in Cura aus: [general] name = 0.4 mm version = 4 definition = ultimaker2_dual [metadata] setting_version = 4 type = variant hardware_type = nozzle [values] machine_nozzle_size = 0.4 machine_nozzle_tip_outer_diameter = 1.05 speed_wall = =round(speed_print / 1.25, 1) speed_wall_0 = =1 if speed_wall < 10 else (speed_wall - 10) speed_topbottom = =round(speed_print / 2.25, 1) Bei Definition habe ich bei Metadata folgendes hinzugefügt, dass die Materialien aus den Standardeinstellungen gezogen werden: "quality_definition": "ultimaker2_plus", "has_variants": true, "has_materials": true,
  11. Stan-D

    X or Y switch brocken

    Hatte heute das selbe Problem nach dem Aufspielen der Firmware in der Z-Achse... Die E-Steps waren auf allen Achsen und Extruder auf Wert 0 gestellt! Dachte erst an einen defekt im Endschalter, nach Durchmessen aber alles i.O. gewesen! Hast du evtl. eine neue Firmware aufgespielt?
  12. Stan-D

    Hallo

    Moin, moin... Als Erstes solltest du nach dem Ausschlussverfahren agieren! Als Ursachen kommen diverse Fehler in Frage 1. elektrisches Problem ( Verkabelung falsch ) Endschalter falsch angesteckt, Kabelbruch oder Wackelkontakt der Steppermotoren oder der Endschalter ( Bruch einer Leitung reicht aus. ) 2. Mechanisches Problem - Blockaden in der Bewegung oder ähnliches... Zur Ursachenforschung ist es hilfreich die einzelnen Achsen anzusteuern und einzelne Home-Positionen anzufahren. Ich nutze hierfür Slic3er.
  13. Stan-D

    Hallo

    Hi, habe mittlerweile die Ursache finden können... Es ist nicht das Board, sondern die Steppermotoren, die am UM1 Gehäuse anliegen. Das Gehäuse verhält sich dadurch wie ein Resonanzkörper ähnlich einem Lautsprecher. Werde da noch die Bohrungen nacharbeiten um etwas Platz zu schaffen und andere Motorhalter drucken, dann ist es mit der Geräuschkulisse akzeptabel. Gruß
  14. Stan-D

    Hallo

    Danke schon mal für die Antwort... Was ist denn gleich laut? Mein Board macht in der XY Bewegung laute fliepende Geräusche, wie das mit den alten Boards und Steppern ist. Wenn ich Videos diverser UM2 oder UM2+ sehe, sind diese doch nicht mehr am "singen". Die eingelöteten Steppertreiber auf meinem Board sind A4988. Sind diese auch beim originalen 2.1.4?
  15. Stan-D

    Hallo

    Hi, ich habe mich hier neu angemeldet, da ich ein Einsteiger im Bereich des 3D-Drucks bin und ggf. etwas Hilfe bzw. Tips benötigen werde... Einen 3D-Drucker habe ich schon länger auf dem Schirm, da ich vorläufig nicht sehr viel Geld für einen neuen Drucker ausgeben wollte und das basteln mir auch Spaß macht, habe ich mir einen 3D Drucker-Mix aus der Ultimaker-Familie 1bis2+ zusammengebaut. Das Gehäuse vom UM1, Druckkopf vom UM2+, GT2-Riemen und Riemenscheiben, Feeder vom UM2, handgerichtete Präzisionswellen, Display 2.1 und Mainboard 2.1.4 Clone aus China. Mit den ersten Drucks und auch mit der Druckqualität bin ich mehr als zufrieden. Leider ist das "Chinaboard 2.1.4" sehr laut, was die Stepperansteuerung betrifft. Ich wollte halt keine 350,-€ für ein Original ausgeben. Hat jemand hier aus dem Forum ein "Chinaboard 2.1.4" am laufen und ggf. eine Abhilfe über Marlin Configuration oder einen anderen Ansatzweg außer neues kaufen oder anderes wählen...
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!