Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
msurunner

Newbie... Lack of sleep... Help please!

Recommended Posts

Okay guys, so I'm a new teacher that just assembled an Ultimaker for use in my classroom. I purchased with it the UltiController. I assembled it and it had some issues of not allowing the user to control it directly from the UltiController. It did, however, allow for it to find home and displayed information on the UltiController, it just wouldn't allow me to use the controller to move the axes or initiate the heater. After reading more in depth, I assumed my Ultimaker was pre-loaded with 5D (correct?) and that I needed to upgrade the firmware to Marlin to utilize the Ulticontroller (correct?). I upgraded the Arduino to Erik's Marlin and tried it again. Now the UltiController does not display any information, despite switching cables around. Given that I was able to send information and receive information before the firmware update, I'm doubting the cables would be the issue (correct?). At this point, I'm just hoping to connect it to a CPU unit and test it's print settings to ensure everything works, but now I'm unable to connect to the machine in ReplicatorG, throwing an unable to reset error. Thoughts?

Having stepped into a room with some other serious issues, I'm hopeful I can concentrate on those for a couple days and that you Ultimaker Geniuses have the simple answer my underslept mind missed. Thanks guys!

Share this post


Link to post
Share on other sites

Dear MSURunner,

Can you tell me what you have tried to move the printhead or heat it?

It should have been sent with Marlin 2.0

But no worries:

If you are using ReplicatorG, upload the firmware to Marlin 2.0

If you are using Cura, upload 'Default firmware'.

This should help you using the UltiController.

The flat grey cables are not the problem. They can give u 2 options, either you see 2 bars (which is wrong)

or it shows the menu (which is good).

Can you acces the files on your SD Card?

Please check the firmware and let me know if this works.

Share this post


Link to post
Share on other sites

I tried to move the print head with the Ulticontroller in its menu, but the only movement I was able to get was the autohome function. It would not respond to moving the axis or heating the print head. I also tried to connect to it using ReplicatorG, but it keeps failing to make a connection, serving up a RTS failed to reset error. As I connect the UltiController now, I show only blocks across the display (regardless of cable orientation). Is there a place to download the Marlin 2.0 firmware outside of ReplicatorG/Cura? If not, is Cura the better option? If RepG, which version? Sorry for the fourteen hundred questions!!!

Share this post


Link to post
Share on other sites

Sounds like a MINTEMP or MAXTEMP trigger. Which stops the motion of the axes, and stops the heater from working.

This happens if the wires going to the temperature sensor are not properly screwed in, make sure those small screws are really tight, and make proper electrical connection.

Share this post


Link to post
Share on other sites

I think that may have been the issue. I reflashed it with Marlin 2.0 from Cura and swapped/rechecked connectors. My only issue now is adjusting things I think... I can't seem to maintain a consistent flow rate through the printing of a part. I've tried turning up the temp to 260 and slowing the speed down to 50% (which seems to work well to start) but by the end of a part it seems like the print head is starved for PLA.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Introducing Ultimaker Cura 3.6 | Beta
      Ultimaker Cura 3.6 | Beta is available. It comes with new features, bug fixes, and UX improvements. We would really like to have your feedback on it to make our stable release as good as it can be. As always, you can download the beta for free from our website, for Windows, MacOS, and Linux.
        • Like
      • 93 replies
    • Print Core CC | Red for Ruby
      Q: For some users, abrasive materials may be a new subject matter. Can you explain what it is that makes a material abrasive when you are not sure which print core to use?
      A: Materials which are hard in a solid piece (like metals, ceramics and carbon fibers) will generally also wear down the nozzle. In general one should assume...
        • Like
      • 30 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!