Jump to content
frederiekpascal

reprap mode and Cura 15.06.03 possible?

Recommended Posts

Posted · reprap mode and Cura 15.06.03 possible?

Topic says it all :)

Is there a way to enable reprap mode in Cura 15.06.03 on Mac?

I'd like to know it for my Octoprint with my Raspberry Pi.

Thanks a lot! :)

Share this post


Link to post
Share on other sites
Posted · reprap mode and Cura 15.06.03 possible?

@nallath actually he's talking about the gcode flavor, on the previous versions of Cura it was possible to change it in the machine settings.

He needs to change the GCode flavore from UltiGcode to reprap in order to use it with octoprint

Share this post


Link to post
Share on other sites
Posted · reprap mode and Cura 15.06.03 possible?

Well, the machine settings have a setting called "machine_gcode_flavor" (which defaults to "RepRap")

Share this post


Link to post
Share on other sites
Posted · reprap mode and Cura 15.06.03 possible?

Well, the machine settings have a setting called "machine_gcode_flavor" (which defaults to "RepRap")

 

in Cura 15.06.03 on Mac?

are you sure? cause I checked all settings available and no gcode flavor setting....

Share this post


Link to post
Share on other sites
Posted · reprap mode and Cura 15.06.03 possible?

It's defined as a machine setting. This is not something you can change in the user setting (same goes for build volume). This is why you need the right setting file for your machine.

Share this post


Link to post
Share on other sites
Posted · reprap mode and Cura 15.06.03 possible?

nvm, the new version of cura doesn't have the feature to change the gcode flavor :p

installed an old version and all ok now! ;)

Share this post


Link to post
Share on other sites
Posted (edited) · reprap mode and Cura 15.06.03 possible?

anybody who can help me out?

 

Your're quite insistent, aren't you? :)

Solution1 is obvious - use Cura 15.04 for now (GCode flavor is editable in previous versions of Cura) - and jangle Nallaths nerves until it is integrated in the new version... :)

Solution 2: Add the "Ultimaker Original+" as printer and generate your gcode with this one.

Solution 3: edit the settings manually - find the file ".../resources/settings/ultimaker2.json" and change "machine_gcode_flavor" from "UltiGCode" to "RepRap (Marlin/Sprinter)"

Pleased?

Edit: i'm always too slow... :)

Edited by Guest
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!