Jump to content
Ultimaker Community of 3D Printing Experts

Settings in a customized firmware doesn't work no matter how I change it


tigertooth4
 Share

Recommended Posts

Posted · Settings in a customized firmware doesn't work no matter how I change it

Hi friends,

Please help! I cannot make my settings in the customized Marlin firmware work. Here's my story:

I'm using a UM2. I was going to change the

FILAMENT_FORWARD_LENGTH

parameter to make the fast forward length shorter, otherwise I found the filament was reaching the nozzle at a very high speed, which constantly causes heavy filament grindings.

So I download the source code from the official github: ultimaker2marlin, found the file UltiLCD2_menu_material.h and changed the

FILAMENT_FORWARD_LENGTH

in the file from

(FILAMENT_BOWDEN_LENGTH - 50)

to

(FILAMENT_BOWDEN_LENGTH - 100)

where FILAMENT_BOWDEN_LENGTH = 705.

Then I compiled the firmware by following the knowledge I've got so far: with Arduino, commenting out the

ISR(TWI_vect){...}

part in twi.c, compiled it and uploaded the .hex file by using Cura 15.04. I was sure for the successful firmware update because I saw the version changed to my customized one in the LCD menu.

But the forward length seemed not changed at all. Grinding happened as before. So I changed FILAMENT_FORWARD_LENGTH to (Bowden_length - 150). Again, no visible difference was shown. The fast filament feeding still went like nothing was changed.

To understand what was happening I used G-code G1 E-100 in printrun, and measured the outgoing filament. I found the outgoing length was almost 200mm, twice as it should be! I thought that might be the reason, perhaps every length was doubled, therefore even (Bowden_length - 150) were still longer than the actual length of bowden tube because of this doubling!

I thought the reason for doubling was the wrong setting in the configuration.h: I found the DEFAULT_AXIS_STEPS_PER_UNIT for extruder was 282, which I thought should be 125 or so since I had a φ8.1 feeder wheel (if I did the math right). Then I changed it to 125, expecting the 100mm feeding length instead of 200.

But after uploading my changes, nothing changed. The G-code feeding G1 E100 (or -100) is still 200mm filament in output.

So it turns out nothing have changed no matter how I was tweaking the settings in Marlin. So I'm totally confused! Did I did something silly? Does anyone use a customized firmware? Any clues will be appreciated ! Thanks!

Best,

XJ

  • Link to post
    Share on other sites

    Posted · Settings in a customized firmware doesn't work no matter how I change it

    Thanks very much! That's exactly what I'm looking for!

     

    So  - you changed the default settings and compiled it into your firmware. That's not wrong, but those settings are stored in eeprom and can be changed via gcode commands.

    The new defaults will only be used after a "Factory reset"...

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...