Jump to content
Ultimaker Community of 3D Printing Experts
thirty6

Heated Bed Official Kit Stretched Z

Recommended Posts

Hi

I have been asked to start this as a new topic and I you can help. UM original now with the official heated bed kit fitted, and i am now getting a bad stretch in the Z direction. If i print a 10mm cube to check dimensions the results are 9.58x 9.46y 12.7z mm.

I updated the firmware through Cura 15.02.1 and used the corrected heated bed option and now have HBK 250000.hex installed.

It printed great as a standard machine, so what i have i done since upgrading??

IMG_0934.thumb.jpg.24c6b2daa17919e03c4075f423d083ea.jpg

IMG_0934.thumb.jpg.24c6b2daa17919e03c4075f423d083ea.jpg

Share this post


Link to post
Share on other sites

Can you please do the following:

 

  • autohome the hotend (prepare -> autohome)
  • move the printbed 100mm downwards (prepare -> move axis)
  • measure how much you actually moved (with a pocket rule or sth like that)

 

and, can you tell me your current Z-steps/mm? (Ulticontroller: Control -> Motion)

Edited by Guest

Share this post


Link to post
Share on other sites

533.3 is correct for an ultimaker original without the new lead screw (i heard they changed it, but i don't have an heated bed...).

I don't know the new value but i will see if i find it in MARLIN somewhere.

But anyway, it's strange... are you sure that the new firmware is installed?

Edited by Guest

Share this post


Link to post
Share on other sites

Take a look here:

https://github.com/Ultimaker/Marlin/blob/Marlin_UM_HeatedBedUpgrade/Marlin/Configuration.h

There is one line there that is important:

#define DEFAULT_AXIS_STEPS_PER_UNIT   {78.7402,78.7402,200.0,760*1.1}

Therefore the z-Steps/mm should be 200.0, not 533.3 - right?

Are you sure that the new firmware is installed correct?

I will read the instructions for the heated bed... i'm a bit confused since i don't have it installed

Edited by Guest

Share this post


Link to post
Share on other sites

Well, I found the problem I guess!

If you upload a new firmware, it will not override the values you stored once in the EEPROM.

Therefore, do the following:

Ultimaker controller: Control -> Restore Failsafe

That command (GCODE: M502) replaces the values in SRAM with the ones in the firmware.

 

// M502 - reverts to the default "factory settings". You still need to store them in EEPROM afterwards if you want to.

 

Now you can store them again in the EEPROM (GCODE: M500):

Ultimaker controller: Control -> Store Memory

B.t.w.: Since the following lines aren't commented out in your firmware, EEPROM is enabled by default

 

#define EEPROM_SETTINGS#define EEPROM_CHITCHAT

 

Edited by Guest
  • Like 1

Share this post


Link to post
Share on other sites

I installed mine last weekend - I like it but

there are also some things they should change...

you cannot fix the backside of the wooden part to the metal plate.

they removed the "hook" for the lower z-endstop

the metal plate is a bit unstable, you can bend it easily if you push the frontside down :/

ah yes the glue stick... what is it good for? :D

Edited by Guest

Share this post


Link to post
Share on other sites

you cannot fix the backside of the wooden part to the metal plate.

 

Actually you can, step 58.

 

they removed the "hook" for the lower z-endstop

 

That is because UMO's home upwards

 

the metal plate is a bit unstable, you can bend it easily if you push the frontside down :/

 

Yeah, same here, but during printing it seems ok actually!

 

ah yes the glue stick... what is it good for? :D

 

It helps the print stick, although I've heard people swear all kinds of different things work.

 

Share this post


Link to post
Share on other sites

Actually you can, step 58.

 

Yes, but that's just the frontside of the wooden enclosure. If i tighten the screws, the backside of the wooden part lifts up a bit and becomes askew and scratches the back panel.

There are two two holes in the metal plate which are unsued, looks like they just "forgot" to cut out holes for the nuts^^

 

That is because UMO's home upwards

 

Yes right, but if you print a very high model... and software endstops aren't enabled... :D

 

Yeah, same here, but during printing it seems ok actually!

 

Just looks a bit unprofessional

 

It helps the print stick, although I've heard people swear all kinds of different things work.

 

You mean if you don't turn on the heated bed, right?

Edited by Guest

Share this post


Link to post
Share on other sites

Its Elmers PVA that people rave about in the US i think.

Heat the bed to 60deg, brush the 50/50 mix on and let it dry, then print.

Everything sticks and comes off with a high gloss base, XT, PLA, Nylon etc.

Okay you can use the glue stick that comes with the kit but I prefer the brush on method for a cleaner finish. I use it on my UM2, UM 1's and the Printrbot Plus.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!