Jump to content
Ultimaker Community of 3D Printing Experts

I want to start using plugins

Recommended Posts

Hi I found some useful plugins for cura which I want to try out but can't find a step by step manual or tutorial how this works. What i did found was to put the plugins in de plugin folder but:

- Which file(s) are the actual plugin and what additional files should be places in the folder?

- Do they need to be placed in a parent folder or just all together in the main plugins folder? (some plugins contain a lot of different file types)

- Do I have to do this by just draging them into there or do the files need to be installed somehow?

- Do I need to restard Cura to make files visible? How do i get to see them in Cura?

I've tried several things but nothing worked so far.

I'm using the latest Cura version in advanced mode for mac.

How to I get this to work please?

Thanks for any help!

Best regards, Mickael

Share this post

Link to post
Share on other sites

There are two "latest" versions of Cura. You have the 15.04 and the 15.10 version (renamed to 1.99). The 15.04 version uses a very limited plugin system which only allows you to perform post processing on g-code.

The 'new' Cura on the other hand has a very advanced plugin system that allows you to add new tools, do post processing, add new rendering types, new file types and even change the backend.

Both work quite differently with regards to how to add plugins.

That being said; What did you try? (and didn't work)

  • Like 1

Share this post

Link to post
Share on other sites


I'm using Cura 15.04.3 for mac.

The open plugin location button does not seem to work and placed plugin files in the Cura Plugin folder (copied in this folder) did not show up in the available plugin list within Cura (also after restarting Cura and after reboot.

I could not find a step by step manual how to install the plugins, so I don't really know what I have to do...

Share this post

Link to post
Share on other sites

Did you put the plugin's .py file in the /Contents/Resources/plugins folder contained in /Applications/.../Cura 15.04.app? If so, a restart of Cura is enough to make it usable.

I'm on OS X 10.9.5 with Cura 15.04.3.


Yes I did that but after restart nothing showed up...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 114 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!