Jump to content
Ultimaker Community of 3D Printing Experts
fourier

UM2 skipping multiple layers in a print?

Recommended Posts

For a reason I can't determine, this has happened a couple times already. I come to check in on a print, and the print is perfect up to a point, at which point it's spaghetti, and the buildplate is WAY lower (like sometimes nearly a centimeter) than it's supposed to be. I have no idea what's causing it. I've checked the g-code thoroughly in multiple viewers and the slicer itself (Simplify3D) and there doesn't seem to be any such issue in the g-code.

I am printing from SD card, by the way. The printer's only about a week old, so I am really hoping it's not something hardware related.

Edit: it's a plain UM2 by the way.

Edited by Guest

Share this post


Link to post
Share on other sites

There's several possibilities. For example maybe it stopped extruding for 20 minutes and started back up. Much more likely though the Z axis slid down. You don't say which printer but the metal beds on the UMO+ and UM2 and UM2ext are quite heavy and if the Z stepper loses power it's common for the bed to slide down a bit and the stepper driver will cut power if it gets too hot. This has been a problem for many people with boards made in the last year and the solution is to lower the Z stepper current down to 1000ma. You should be able to set it from the front panel but will lose the setting on power cycle unless you save with I believe an M500. Try it first and if this fixes the problem ask how to save the setting permanently.

Share this post


Link to post
Share on other sites

Yeah I mentioned it's a UM2 in the topic, but didn't in the post.

I will try lowering the power. I'm familiar with Mxxx codes (I also have a Printrbot Simple Metal, an M500 + M501 is practically a daily operation for using it!), so I'll do that. I wasn't keeping track, but from memory, it would make sense that it is overheating. The prints I recall them failing on were fairly long (3+ hour) prints. There was also a bit of clicking, which initially I associated with the extruder, but never made much sense since the print wouldn't have issues. Might have been the z-stepper losing power for a brief moment!

BTW, M500 = save, M501 = recall saved settings (to confirm they saved correctly).

Edited by Guest
More detail.

Share this post


Link to post
Share on other sites

Well if you like gcodes you can do it all through that:

M907 Z1000

sets the Z driver to 1000ma max.  default I believe was 1300ma for a while (and on my printer)  and newer software are at 1100ma default for Z I believe.  I thinK default is now:

M907 X1300 Y1300 Z1000 E1250

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!