Jump to content
Ultimaker Community of 3D Printing Experts
Mils24

Cura 15.04 Delta Movement issue

Recommended Posts

Hey guys I have been using Cura for over a year now with my homebuilt Delta machine without any issues.

At the weekend I updated Cura to 15.04 as I just bought a second hand Ultimaker 2 and wanted to update the firmware to the latest version.

However last night I tried to run a print on my delta using the latest Cura and it will not print. When the print goes to start and the print head lowers towards the bed one of my towers stops after about 30mm of travel and the other two continue to move. This forces the head toward one of the towers at quite a bit of speed. Luckily I managed to hit the reset button before any damage was done to my machine as I am convinced it would of snapped the rods if it continued to move.

I tried deleting the gcode file and re saving it to the SD card but it made no difference. I also tried deleting my 'machine' settings and setting up as a new machine, again without any luck.

Finally I had a gcode file from my old Cura installation still on my SD card and tried to print it, which it did without any movement issues at all.

Very strange and need any help I can get as Cura is my far preferred slicer and I don't want to have to change to another if possible.

Many thanks.

Share this post


Link to post
Share on other sites

It looks like Cura confused your machines and tries to control it like a cartesian printer. I'd suggest to delete the Delta from Cura and add it again. Or maybe you just forgot to switch to the delta when you started the print and the UM2 was selected.

Share this post


Link to post
Share on other sites

I suspected this may be the case.

I have already deleted my old Delta machine settings and set up as a new delta.

I also made sure the delta machine was the active machine when compiling the print data.

However neither of these made a difference.

Only thing I haven't tried is to delete the UM2 Machine from Cura and try again.

I will do this tonight and revert back.

Share this post


Link to post
Share on other sites

Keep in mind that unlike most software, when you install a new version of cura the old version is still there. Windows considers them all separate programs. This makes it very convenient to switch versions of cura depending on the needs-of-the-day.

So you can always "go back". Plus all the old versions of cura are available for download.

http://software.ultimaker.com/old/

Now to your problem: part of the cura settings (for non-ultigcode like delta printers) should have the start and end gcodes. Compare these to the values in the old version of cura. Something is probably different here that you forgot about. For example do you have an M665 in the gcode files created by the older cura?

If those all look perfect then slice the same 10mm cube with the same settings and compare the gcodes of the output files. The problem should occur very early on. also in machine settings did you remember to set 0,0 as the *center* instead of the corner?

Share this post


Link to post
Share on other sites

Sorry I forgot to say that I may using the Mac version of Cura and unfortunately once you remove the old version it's gone. Therefor I only now have the latest version on my system.

However as I said in the OP I have GCode files saved on the SD card and will check the GCode data for the commands you mentioned and let you know.

Share this post


Link to post
Share on other sites

At least you don't end with gazillions of useless folders, like the folder /Windows

Just rename the App folder to Cura-old and install any version you want. No need for uninstallers with 10 windows to find the stuff. Just rename, and enjoy.

Edited by Guest

Share this post


Link to post
Share on other sites

I far prefer the MAC version of anything over Window for the exact reason 'neotko' talked about. Too many hidden folders and 'rubbish' with windows to clean up after an uninstall.

UPDATE:

Last night I re installed the version of 15.04.05 that I downloaded and tried again with no success. I also deleted again the custom Delta profile that I had made for my machine and re made it. Again with no success.

I then deleted the Ultimaker 2 machine profile as I thought it may of been causing my delta profile to think it was a cartesian printer. However with the UM2 profile deleted it still did not make a difference. (only my single custom Delta profile remained within Cura)

Finally I then set up a new machine and selected the 'deltabot' pre made profile. This did fix my initial issue however the movement from the home position towards the bed was jumpy and jittery therefore still not a final fix - it essentially just changed the error to a new one.

My settings for my profile are:

Esteps - 0 (firmware value used)

size - 270

size - 270

height - 250

nozzle - 0.5

heated bed - yes

bed 0,0,0 - yes

bed - circular

GCode Flavour - RepRap (Marlin/Sprinter)

Please note that I also tried setting up a machine as per above but with the GCode flavour set to 'RepRap Volumetric' (from memory this option was not in 14.03) and it behaved in the same manor as the 'Deltabot' pre-made one. It fixed my initial issue but when moving from the homed position to the bed it jumped and jittered and did not move smooth as before.

Any and all help GREATLY appreciated and any further help or information you require please ask.

Thanks

Share this post


Link to post
Share on other sites

"Volumetric" will only affect the extruder. It will extrude the wrong amount if you do that - other than that there is no difference.

Well do you have old gcode files from when it used to work fine? Can you compare the top 30 lines or so? I mean there's not much there and most of the commands should be identical so probably only 5 gcodes are different from the old to the new.

Basically you want to look at what you have now in the "start" tab of cura - the gcodes there and compare that to what it creates now. Then compare that to an old gcode file and make the new gcode files look like the old ones that worked.

Share this post


Link to post
Share on other sites

As peri Gr5's comments below last night I opened both Gcode files in Cura and 'textedit' (word pad for Mac) and checked the all the 'pre print' Gcode. Everything was the same appeart from the speed at which it moved the print head towards the bed.

Old 14.03 file - F6000

New 15.04.05 file - F9000

Therefore I sliced another part and modified the Gcode to be F6000, however it didn't make a difference.

I then tried F5000 and surprisingly it didn't stick!! It moved towards the bed as it should however it sounded noticeably louder and it wasn't as 'smooth' as it should be.

I then tired again with F2500 and it jammed as per the original problem.

After this I uninstalled 15.04.05 and reinstalled 14.03, however now it is not working either!

There doesn't seem to be any logic to this problem

Share this post


Link to post
Share on other sites

I guys I tried emailing the Cura team and they said as I was not using a UM product they could not help me.

You guys are my only hope. Any advice would be greatfull or ideas to try as now the latest or last working version does not seem to make a difference.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • How to 3D print with reinforced engineering materials
      Ultimaker is hosting a webinar where we explain how you can achieve and maintain a high print success rate using these new reinforced engineering materials. Learn from Ultimaker's Product Manager of Materials and top chemical engineer Bart van As how you can take your 3D printing to that next level.
      • 2 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!