Jump to content
Ultimaker Community of 3D Printing Experts
FrankieRomer

UM2 not reading SD card

Recommended Posts

Our UM2 printer has suddenly stopped reading our SD card ( the Sandisk 4GB SDHC that came with the product!)

We have been using it without any issues for the past year, but today it simply will not read the card.

-The SD card can still be read by my laptop and Cura 15.04.5 so I know the card is not damaged.

-We have also tried resetting the UM2 to factory settings and have re-formatted the card FAT32 and have had no luck

-The UM2 reader can also pick up other SD cards so we know the machine is not damaged

Are there any troubleshooting options I can try? We will probably look into getting a new SD card or a Wi-Fi SD card, but it's quite annoying that this has happened of a sudden and I'd like to find out why this has happened so we can avoid this in the future.

Share this post


Link to post
Share on other sites

I guess by the time you buy another sd card you have already recouped the costs for the time you spend fixing this ;)

Maybe you stored the card somewhere where it got damaged and the sd card reader on the laptop might be more robust.

Share this post


Link to post
Share on other sites

I have lost really expensive equipment over the years due to shoddy card readers. It's quite worrying to think that something like this can render a £1000+ piece of equipment useless. I work in a design studio where it runs 24/7 so the less frequently we remove/insert the card I think the safer we will be! Is there any feasibility in a wi-fi card? will it work you think?

Just to add a note: the UM2 software is _15.04 ultimaker 2 (last updated April 2015)

is it worth trying to upgrade?

Share this post


Link to post
Share on other sites

Then I'd suggest you take a look at OctoPrint. It can be installed on a Raspberry Pi and you won't need a sd card any more. Take a look at this guide:

https://ultimaker.com/en/community/18191-howto-octoprint-raspberry-pi-2-und-um2-extended-mit-standard-firmware

Do you mean the firmware? Then I'd say it is safe to install the latest one that comes with Cura 15.04.5.

Share this post


Link to post
Share on other sites

Did you ever find a solution to this issue? I tried another SD card but it didn't work either. I have thought about upgrading the firmware but if I can't read the card not sure about my options at this point. Need look into other methods. If you or someone else was able to resolve please let me know!

Thanks Scott

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 25 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 23 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!