Jump to content
AlanRichard

Cura 2.1 custom printer platform.stl position

Recommended Posts

Posted · Cura 2.1 custom printer platform.stl position

Hi.

I've set up a custom printer .json file (copied from one of the others) with an .STL model of my platform.

My platform .stl ends up with the bottom corner located at the centre position of the chequered print area.

I've tried tweaking

'machine_platform_offset'

machine_center_is_zero

machine_width/depth/height

in my new .json and fdmprinter.json (which is inherited) also

I restarted Cura everytime. Nothing seems to change -either the position of the .stl or the shape of the print area.

Does anyone have any tips for this?

(I did search but didn't find anything)

Thanks

-a

(I do like the 2.1 - plenty of knobs and switches!)

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 custom printer platform.stl position

machine_platform_offset -> Offset of the 3D model with regards to the build area (usefull if the center of the build plate model isn't the same as the center of the build area

machine_center_is_zero -> Is the center of the machine the origin (0,0) coordinate? Some machines see the center as origin. Ultimaker2 for instance sees the left front corner as origin.

machine_width/depth/height -> Actual width / depth / height of the machine. This is what draws the build volume cube.

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 custom printer platform.stl position
My platform .stl ends up with the bottom corner located at the centre position of the chequered print area.

The origin of your platform.stl should be in the center (at least in x and y) and not at the upper left corner ...

right: right.thumb.png.a8c3cef8363c3dace081c14a2f81d75a.png wrong: wrong.thumb.png.d1e91d8bc9a0c1fa4486eae1a8629311.png

right.thumb.png.a8c3cef8363c3dace081c14a2f81d75a.png

wrong.thumb.png.d1e91d8bc9a0c1fa4486eae1a8629311.png

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 custom printer platform.stl position

Hi.

Thanks for the replies.

I'm still struggling . . .

I was going to write this:

nallath

Changing machine_width/ depth to something obviously odd e.g. 1300 x 50 or as an equal cube it doesn't change the appearance of the build volume cube. I tried it in my new created .json and also fdmprinter.json.

Same with the offset, it doesn't move the platform.stl

I tried reboots and restarts just in case.

It always inserts the correct .STL I created for the platform, as I've changed it a couple of times.

(So nothing so dumb as I'm editing the wrong files or something!)

Thanks berndjm

That seems good advice but how do I change the origin in the .STL?

I've drawn it in 2 different CAD programs with the origin as centre top (it was front corner) it doesn't change the position.

. . . but

I came to the conclusion that my changes were't taking effect.

I tried creating a new machine .json but it didn't show up in the list of printers.

I decided to delete/ reinstall cura and delete my configs. And now I can't seem to add a new printer.

Umm.

So I'll have to poke around and get back to you.

Thanks again

a

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Cura 2.1 custom printer platform.stl position

Hi.

I've got it now.

I can't say what it was though. Odd but it wasn't updating any changes.

I started from scratch again.

machine_platform_offset and machine_width/depth/height did what it should.

Regards

-a

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 181 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!