Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
thelostbrain

Updated to Marlin...Extruder Speed!... M92 E100?

Recommended Posts

Good day all.

After endless attempts and reading I finally managed to stumble my way through updating to Marlin. :)

However, now when attempting to print anything the Extruder wants to spin so fast I don't dare allow it to engage the filament.

Did some trolling and found the 'M92 EXXX' command, but I have to set it very low (E100) compared to other postings to get it to even look like it's close to the correct speed - Does that sound right? I'm thinking I'll need to determine the correct value for my machine and eventually set it in the configuration.h but I'm not positive.

Have I missed a step or done something wrong along the way?

This is what I'm currently running... is this what I should be on at this point?

Firmware: ErikZalm-Marlin-45464f8 (

https://github.com/ErikZalm/Marlin/tags

)

Arduino: Version 0022 (Any version higher gives errors when attempting to compile)

RepG: Version 0025

NOTE: I also tried the Marlin_v1 branch but found that the limit switches / end stops were completely ignored!

Thanks for any help!

Mike

Share this post


Link to post
Share on other sites
After endless attempts and reading I finally managed to stumble my way through updating to Marlin. :)

However, now when attempting to print anything the Extruder wants to spin so fast I don't dare allow it to engage the filament.

Did some trolling and found the 'M92 EXXX' command, but I have to set it very low (E100) compared to other postings to get it to even look like it's close to the correct speed - Does that sound right? I'm thinking I'll need to determine the correct value for my machine and eventually set it in the configuration.h but I'm not positive.

The M92 E9xx.xx command sets the steps per mm filament in the firmware, which works great will all current volumetric slicers (skeinforge 40+, slic3r etc).

you seem to be using netfabb, which requires specifically M92 E14 in your start.gcode

Share this post


Link to post
Share on other sites
The M92 E9xx.xx command sets the steps per mm filament in the firmware, which works great will all current volumetric slicers (skeinforge 40+, slic3r etc).

you seem to be using netfabb, which requires specifically M92 E14 in your start.gcode

That's the weird thing... I haven't touched netfabb yet. I've just been testing w/ skeinforge 35 and 40 right from within RepG.

The default Configuration.h in the Marlin 1.0B1 has the following defined for the steps per unit:

#define DEFAULT_AXIS_STEPS_PER_UNIT {78.7402,78.7402,200*8/3,760*1.1}

Does that 760*1.1 look correct? (That is the one for the extruder stepper, right?)

BTW: Even though I just recently got a chance to build my Ultimaker it originally shipped out on 18.08.2011 - Is it possible that I have some older components in my build that may need accounting for in the newer firmware?

Thanks!

Share this post


Link to post
Share on other sites
I've just been testing w/ skeinforge 35 and 40 right from within RepG.

You should be careful mixing SF versions before and at/after 40..

Versions before 40 (and netfabb, for now) should have a "M92 E14" at the top of the gcode file. Versions >= SF40 should have "M92 E865.888" at the top of the file.

The deal is that about a year ago, we figured out a better way for the slicer to tell the machine how much material should be extruded. This was great in that it made calibration a LOT easier (started at SF40) but it also was a bitofa incompatible change - gcode generated with SF39- wouldn't work on machines that expected the new way of doing things and gcode generated with SF40+ wouldn't work on machines expecting the old way..

The M92 was added as a way to tell the firmware which method the slicer used. If you're using sprinter/marlin and have the (correct) M92 setting at the top of your gcode files, you should be ok. If you don't have the M92 at the top of the file, the firmware is going to use whatever value was used last or whatever default value is in the source code - might work good, might go totally pear shaped...

 

BTW: Even though I just recently got a chance to build my Ultimaker it originally shipped out on 18.08.2011 - Is it possible that I have some older components in my build that may need accounting for in the newer firmware?

Unlikely..

Share this post


Link to post
Share on other sites

Versions before 40 (and netfabb, for now) should have a "M92 E14" at the top of the gcode file. Versions >= SF40 should have "M92 E865.888" at the top of the file.

The deal is that about a year ago, we figured out a better way for the slicer to tell the machine how much material should be extruded. This was great in that it made calibration a LOT easier (started at SF40) but it also was a bitofa incompatible change - gcode generated with SF39- wouldn't work on machines that expected the new way of doing things and gcode generated with SF40+ wouldn't work on machines expecting the old way..

The M92 was added as a way to tell the firmware which method the slicer used. If you're using sprinter/marlin and have the (correct) M92 setting at the top of your gcode files, you should be ok. If you don't have the M92 at the top of the file, the firmware is going to use whatever value was used last or whatever default value is in the source code - might work good, might go totally pear shaped...

 

Thank you! That makes everything crystal clear! I think I'll be doing some testing as soon as I get home today. ;)

Thanks so much again!

Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!