Jump to content
UltiMaker Community of 3D Printing Experts

Simplify3D retraction bug that can drive you nuts :)


Recommended Posts

Posted (edited) · Simplify3D retraction bug that can drive you nuts :)

This is bug that has been quite weird, but I think some users on S3D forum reported it, year ago, and still is unfixed and seems noone explained why or how to reproduce it.

So, here I go =)

When using multiple processes S3D thinks of each process as a new print, and their planner aligns them so they print 'right'. The problem with this is that he also thinks that when moving from process A to B the tool is different, so, he does a Tool Retraction Distance if you have wipe at the end of a loop, or Z change... Well, mostly, it does it correctly, but it forces a very very long retraction, that can end up adding blobs (because the head stays retracting more time) or it could, on Full Metal hotends, to clog.

So... If you use one hotend, just change the Tool Change to 0, distance 0, but don't touch the speed (or set is as the same your main settings use)

But if you use Two or more hotends, you will need to make your own toolchange retraction distance on the toolchange script area (not hard at all).

So to show my point, I just made made two prints one with this


And other with the values set to 0 (again, except the speed)

And as you can see, the retraction bug disappears


So, if you use S3D multiple process, and a single hotend, or two, and you want to enjoy the wonders of wipe, coasting, retract-while-wipe, etc.. You NEED to set the toolchange distance to 0 and if you use multiple hotends, make your own E- script for the tool change.

And, why this is important btw? Because the bug makes the whole print slower, and full of weird retraction distances. Check this Gcode compare, Left is bad, Right is ok. For Full metal hotend users, this is a very important thing to check.





Edited by Guest
  • Like 3
Link to post
Share on other sites

Posted · Simplify3D retraction bug that can drive you nuts :)

Do I understand you correctly?, only with activated setting "Perform retraction during wipe movement" occurs the bug!


Wipe also, is a problem of moving from one process to other. Coasting also too. Without perform retract during wipe it can also happen with retract while changing Z.

  • Link to post
    Share on other sites

    • 1 year later...
    Posted · Simplify3D retraction bug that can drive you nuts :)

    Dude :|

    Dont get me started on retraction problems.

    Every damn software i tried to this very day has it.

    Its either retracting or not retracting when you expect it.

    I am assuming its because people who designed these software have crappy extruders that are not capable of handling lots of extrusions like my extruder does.




    Simplify3D a $150 or what ? *|



    Matter Control (a joke that uses OTHER slicer engines such as CURA and REPETIER because its own is garbage)

    SliceCrafter (has no retraction option whats so ever)

    just to name a few i tried.

    I am tired of this. Wish i could program my own.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    • Create New...