Jump to content
Ultimaker Community of 3D Printing Experts

Disable temperature control at cura (2.6)


chrii
 Share

Recommended Posts

Posted · Disable temperature control at cura (2.6)

Hello guy`s,

I want to use cura also on my old non UM printer.

At this printer i want to control the temperatures manual.

i disabled the "heated bed" to get rid of the control at the bed, but i haven`t found any similar option for the extruder to disable the control.

Also setting all (possible) settings to zero did not resolve my problem.

any idea how i can disable it ?

sincerly Chri

  • Link to post
    Share on other sites

    Posted (edited) · Disable temperature control at cura (2.6)

    Set the extruder temp to zero?

    ...later...

    No, that would just set the temp to zero when the print starts.

    Edit the gcode and remove the temp settings.

    Edited by Guest
  • Link to post
    Share on other sites

    Posted (edited) · Disable temperature control at cura (2.6)

    You need to define your printer as using RepRap-type gcode, i.e. in the Printer Settings panel, select Gcode Flavor = Marlin/Sprinter or other non-Ultimaker type

    That will expose extruder and bed temperature settings in Cura.

    Edited by Guest
  • Link to post
    Share on other sites

    Posted · Disable temperature control at cura (2.6)

    Set the extruder temp to zero?

    ...later...

    No, that would just set the temp to zero when the print starts.

    Edit the gcode and remove the temp settings.

    thats what i`m doing at the moment, i have to edit every gcode file, but it is annoying to do this every time

    other slicers do have a the feature when setting the temperature to zero they interpret this as disable the temperatur control/command, thats why i tried it out.

    You need to define your printer as using RepRap-type gcode, i.e. in the Printer Settings panel, select Gcode Flavor = Marlin/Sprinter or other non-Ultimaker type

    That will expose extruder and bed temperature settings in Cura.

    for sure i added my printer as "Custom FDM Printer" , and Marlin Gcode flavor, and the temperatur settings are all there, but i want to disable the control at cura at all not set it manually there.

    Chri

  • Link to post
    Share on other sites

    Posted (edited) · Disable temperature control at cura (2.6)

    Two options:

    The easiest way is to set the gcode flavor to "Ultimaker 2". This will remove all material settings from Cura for this printer, including the temperatures. Note that it will also set the extrusion to volumetric and disable start & end gcode, as it expects the printer firmware to handle start & end.

    Only disabling temperature control is a bit trickier, because it cannot be done from the GUI. If you create your own printer definition, you can set the "machine_nozzle_temp_enabled" value to False by adding this in the "overrides" section:

           "machine_nozzle_temp_enabled": {
               "value": "False"
           },

    Edited by Guest
    • Like 2
    Link to post
    Share on other sites

    Posted · Disable temperature control at cura (2.6)

    Thanks for your answer, but as you mentioned it already, extrusion would be volumetric what is not enabled on my printer, so i can`t use a UM2 profile for that.

    i just installed Cura 2.6.1 but haven`t found where the printer definition is stored at all to search for that "overrides" part ?

    is there also no option to export a custom printer profile ?

    Chri

    Two options:

    The easiest way is to set the gcode flavor to "Ultimaker 2". This will remove all material settings from Cura for this printer, including the temperatures. Note that it will also set the extrusion to volumetric and disable start & end gcode, as it expects the printer firmware to handle start & end.

    Only disabling temperature control is a bit trickier, because it cannot be done from the GUI. If you create your own printer definition, you can set the "machine_nozzle_temp_enabled" value to False by adding this in the "overrides" section:

           "machine_nozzle_temp_enabled": {
               "value": "False"
           },

  • Link to post
    Share on other sites

    Posted · Disable temperature control at cura (2.6)

    Hello,

    i finally was able to create a own def.json for my printer.

    i also was able to disable at least the M109 waiting for reaching the hotend temperature with :

     

    "material_print_temp_wait": {

    "default_value": false

    },

    But i still was not able to disable the M104 command, i added the following lines

     

    "material_nozzle_temp_enabled": {

    "value": false

    },

    also when using "default_value" instead of "value" the M104 command still will be written into the gcode file :(

    Is there anything else that has to be changed to get rid of the M104 ?

    Chri

  • Link to post
    Share on other sites

    Posted · Disable temperature control at cura (2.6)

    does someone have an idea how to disable the M104 at the end ?

    Chri

  • Link to post
    Share on other sites

    Posted · Disable temperature control at cura (2.6)

    Perhaps it's in the end g-code of your printer? What printer are you printing with?

  • Link to post
    Share on other sites

    Posted · Disable temperature control at cura (2.6)

    Hy Ghostkeeper,

    i`m printing on my orca, and using my own start and end gcodes, which do not have the M104 command within.

    Chri

  • Link to post
    Share on other sites

    Posted · Disable temperature control at cura (2.6)

    Please post your def.json file on pastebin.com (or similar) and let us have a look

  • Link to post
    Share on other sites

    Posted · Disable temperature control at cura (2.6)

    @ ahoeben, i uploaded it here

    Chri

  • Link to post
    Share on other sites

    Posted · Disable temperature control at cura (2.6)

    Try with

    machine_nozzle_temp_enabled

    instead of

    material_nozzle_temp_enabled

    . Also, if you use "value", you should enter a string, like so: (case sensitive)

           "machine_nozzle_temp_enabled": {
               "value": "False"
           },
    

    • Like 1
    Link to post
    Share on other sites

    Posted · Disable temperature control at cura (2.6)

    Thank you,with machine instead of material it is working (or better said not working anymore :D )

    Chri

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 10 replies
    ×
    ×
    • Create New...