Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
dinac

#define DEFAULT_AXIS_STEPS_PER_UNIT - comment

Recommended Posts

in everybody configuration.h stays this code :

 


#define DEFAULT_AXIS_STEPS_PER_UNIT {78.7402,78.7402,200*8/3,760*1.1} // default steps per unit for ultimaker

This last Number 760*1.1 gives 836 steps per E

I think that beside this code it should be comment that is missing everybody:

760*1.1 is for new bolt - think it is v3 version

......but many of us that have v2 bolt and made hot bed this is not working good- it shold be 865

I think that this must be commented in code, because many that must compile new FW for HOTBED will run in problem of extruding to small amount of filament.....

 

Share this post


Link to post
Share on other sites

It doesn't matter if you use cura as this is ignored. In all gcode files generated with cura it says (second line of file):

M92 E836.000000

 

This M92 E___ command sets the steps/mm. This line is in EVERY gcode file cura creates. To set this value, in cura, go to "file" "preferences".

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Terms of Use Privacy Policy