Jump to content
Ultimaker Community of 3D Printing Experts
thagu

HeaterHead Cooling Fan not running

Recommended Posts

Hi

I just assemblet my new ultimaker and it worked fine so far, except the heater head cooling fan doesn't want to run.

Signal was sent by gcode.

So I checked the following:

Fan runs if I connect plug to external source. As well as to the cooling fan connector on the pcb for the fan on the bottem, So, fan and wiring can not be broken.

I checked voltage on the connector for this fan, and depending on the Speed i define, I have voltages between 14V and 19V. Even if I turn of the fan by gcode.

So it seems to me, that I have voltage, but somehow the wrong one. I also tried with other fans, they don't work either.

Can somebode help?

I checked the welding of the Transistor (BD679) mentioned in another discussion, but I think the welding is fine.

Can anybody help?

Thank you

 

Share this post


Link to post
Share on other sites

Thanks for the incredibly fast response.

I always measured the voltage between black and red. How can I measure it with only one wire? (I have a voltmeter, but are not so experienced with it ... ;-) )

I think it's interesting, that the voltage is not correlating to the given rpm's. so, voltage for 70 rpm (m106 S70) is higher then for 200 rpm... it seems to have no correlation between voltage and rpms.

I use the printrun to communicate with the Ultimaker.

 

Share this post


Link to post
Share on other sites

M106 S70 Doesn't mean "rpm 70" it means 70/255 duty cycle. For example S128 would be half on, half off. The fan voltage is turned on and off hundreds (thousands?) of times per second and with S128 it is half the time on, half the time off. S25 would be on 10% of the time and off 90% of the time. S255 is on 100% of the time. If the S value is too low the fan won't spin at all but it should be spinning by S128.

1) When you said the fan was not working, do you mean it didn't spin at all when plugged into the proper connector?

2) When you measured 14 to 19 volts was the fan connected at the time? If not you need to connect the fan and check the voltage again. I'm guessing the fan is drawing too much current for some part of the circuit and that circuit can only supply the voltage if there is no load.

It's backward that S70 has a higher voltage on your meeter than S200 but I'm not too surprised. Your voltmeter is probably digital and probably measures a certain number of times per second. The UM is turning the fan on and off at a certain number of times per second. The times can line up in a way that the voltmeter usually sees the off voltage or the on voltage so the voltmeter is helpful but not telling you the whole picture. If you use a completely analog voltmeter it should be more consistent. Or even better you could use an oscilloscope and see the waveform and see the whole truth (and not just part of the truth) but I don't think any of this helps your problem. Answer #1 and #2 above first.

 

Share this post


Link to post
Share on other sites

By the way you can print with the UM just fine without the fan and many people prefer it that way. You should change one thing in Cura though:

In "advanced" tab "cool" section, set minimal layer time (seconds) to a larger number to allow layers to cool before the next layer is put on top. I normally use 7 seconds with the fan on, but 30 seconds should be more than enough when the fan is on. This number overrides the printing speed for layers that don't have much printing on them and would normally take less than this number of seconds so cura slows down the printing speed here. You might also change another value: in "expert config", "cool" section, set "minimum feedrate" to zero which otherwise overrides the override.

 

Share this post


Link to post
Share on other sites

Hi, Thanks again for your valuable help! Now I think I understand how this fan should work :-)

To answer your questions:

1: Fan doesn't run at all at this plug.

2: If I measure the voltage while plugged in, I get something like 2.4V. No Current (0A).

In the meanwhile, I installed a external fan with external powersource, so I can print with pla. I tried also without fan and it works ok.

 

Share this post


Link to post
Share on other sites

OK, would it be the transistor BD679 with 3 pins, directly beside the fan plug? So I would try to order it somewhere and to fix it by myself.

Or can I check, if really this transistor is broken by installing some kind of workaround (get the voltage before the transistor or sth like that).

 

Share this post


Link to post
Share on other sites

Personally I would look at the 3 pins of the transistor with an oscilloscope with the fan attached and not attached (and perhaps a 100 ohm resistor attached in place of the fan) and try to figure out if it is working or not based on the specs of the transistor. More likely the transistor is inserted backwards or the solder is not a good connection.

 

Transistors are pretty complicated to understand if they are working or not.

 

Share this post


Link to post
Share on other sites

Hi thagu,

I have just completed my Ultimaker and have the same problem with the head cooling fan (doesn't come on), with same electrical symptoms as yours.

Looks like a bad batch of controller boards maybe?

Did you find a solution to this other than running an external fan? I'm trying to print small parts and really need the cooling.

Any help would be appreciated.

 

Share this post


Link to post
Share on other sites

Hi TSAD

thanks for your post. Nice to hear that I'm not the only one.

I didn't have time so far to check further if it's really that transistor, so I used an external fan. (We finally got some summer weather, so I had to stay outside... )

But if I find out anything more I will post it in this discussion.

kr

 

Share this post


Link to post
Share on other sites

Hi Thagu.

After an extensive troubleshooting process, the problem was with the wire connecting the fan to the controller board under the printer. The cable was wired incorrectly (in the factory) so that the positive output on the board was connected to the negative (or ground) input of the fan and vice versa.

This would short out the fan motor (killing the fan) and the burn out the Darlington on the controller board when the fan was switched on for the first time. Before you connect another fan, you will need to correct the polarity of the connector wire and possible replace the Darlington.

From your multimeter readings I suspect that your Darlington may be ok, but you will need a new fan.

Here are the checks that support suggested to check the Darlinton:

1. Check for continuity between the middle leg of the Darlington and the right hand pin of the fan connector on the board (right hand pin when you are looking at the connector from the "outside" of the board - i.e pin furthest from the Darlinton). There should be continuity.

2. Check for continuity between the other pin of the fan connector and the left pin of the connector for the big (centrifugal) fan. There should be continuity.

3. With the fan disconnected from the board but switched on via the software, there should be 19V between the pins on the board.

4. With the fan disconnected from the board but switched on via the software, there should be 5V between the middle leg on the transistor (GND) and the +5V pinout on the board near the LED header. If you get continuity in step 1 above, it is easier to use the right hand pin of the fan connector rather than the middle pin of the Darlinton to test here.

If the above all check out, the Darlington should be ok and it's just a case of swapping the pins in the connector wire and installing a new fan in the print head.

I hope this sheds some light on your problem.

T.

 

Share this post


Link to post
Share on other sites

I too am having the same problem.

I have done the checks and when I check the 5V between the middle leg on the transistor (GND) and the +5V pinout, when the software is not running, I get the 5V, but when the software is running I get approximately 2.3V across these pins.

Really would like to be able to solve this, I have bought a new fan, I have also replaced the BD679 darlington but still everything is the same.

Paul

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 15 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 18 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!