Jump to content
Ultimaker Community of 3D Printing Experts
archprem

ultimaker 3 stops at starting screen (logo)

Recommended Posts

How annoying :( Was it a power-loss during the install? Otherwise can you tell me when you started to update, and from what version?

In the mean time, have a look here. If you have a microSD card ready it should be pretty easy but you do have to remove some of the plastic covers, etc. Let us know if you run into any problems.

If you can't recover the printer on your own you can always get in touch with your reseller they should be able to help you as well.

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 24 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 22 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!