Jump to content
Ultimaker Community of 3D Printing Experts

Komisches Problem mit TinkerGnome beim Homing der Z-Achse


Recommended Posts

Posted (edited) · Komisches Problem mit TinkerGnome beim Homing der Z-Achse

Ich weiss gar nicht, wo ich das eigentlich posten sollte, also versuch ichs mal hier und in Deutsch. Ich hab seit paar Wochen nun die aktuelle Tinkergnome Firmware auf meinem Ultimaker 2+. Im Großen und Ganzen funktioniert das sehr gut, aber anscheinend verliert er irgendwie die Z-Achsenpositionen. Ich level mein Bett, stell die Z-Achse ein, alles prima. Dann endet der Druck, er fährt das Bett nach unten, löst den Endstop aus und ist nun plötzlich der Meinung, er wäre bei Z=~200,, anstatt Z=212,25 (der korrekte Wert). Folglich startet der nächste Druck auch nen guten cm in der Luft.

 

Woher kommt das und wie kann ich das beheben? Wäre für jeden Tipp dankbar.


 

Edited by StephanK
  • Link to post
    Share on other sites
    Posted (edited) · Komisches Problem mit TinkerGnome beim Homing der Z-Achse

    Hallo @StephanK,

     

    Hast du schon ein Factory Reset versucht?

     

    Gruß

     

    Edit: Wenn ich mich nicht ihre, bei ein paar Einstellungen gibt es ja ein Speicherknopf wenn man diesen Taste nicht bestätigt wird nach den ausschalten die Einstellung wieder zurückgesetzt. Kann das vielleicht in Zusammenhang stehen und nicht das es nach jedem Druck sich verändert.

    Spätesten @tinkergnome kann Helfen!

    Edited by zerspaner_gerd
    siehe Edit
    • Thanks 1
    Link to post
    Share on other sites
    Posted · Komisches Problem mit TinkerGnome beim Homing der Z-Achse

    Ja, der nächste Druck war gut, beim Ende des 2. Drucks wieder das selbe Problem: diesmal waren es dann 191mm. Ich verstehs nicht.
    Ich hab jetzt mal im Menü am Drucker den Z-Abstand neu eingestellt, in S3D den End-Script aufs Minimum reduziert und lass ihn jetzt mal nacheinander 2 Testtürme drucken. Mal schauen, was dabei rumkommt.

  • Link to post
    Share on other sites
    Posted · Komisches Problem mit TinkerGnome beim Homing der Z-Achse

    Moin Gerd,

    so, hab weiter experimentiert. Das Problem ist jetzt bei 3 Drucken in Folge nicht wieder aufgetreten. Ein-/Ausschalten kann ich ausschliessen, ich schalte den nie aus. Aber: der hängt an nem RasPi3 (Repetier-Server), und wenn der RasPi sich neu verbindet, resettet der UM2 ja immer. Da werde ich weiter ein Auge drauf halten. Und wenn ich eine Methode zum Reproduzieren finde, poste ich nochmal. Die TinkerGnome Firmware will ich auf jeden Fall nimmer missen, die hätte ich schon viel früher drauf packen sollen ;-)

    Danke Dir erst mal für Deine Hilfe

  • Link to post
    Share on other sites
    Posted · Komisches Problem mit TinkerGnome beim Homing der Z-Achse

    Zu früh gefreut, Problem, ist wieder da. Wieder startete der nächste Druck nen guten cm über dem Druckbett. Drucker war nicht ausgeschalten, kein RasPi Reset dazwischen. Nächster Test: ich drucke von SD-Karte, mal schauen, was dann passiert.



     

  • Link to post
    Share on other sites
    Posted · Komisches Problem mit TinkerGnome beim Homing der Z-Achse

    Wie sieht denn das Start-/End-Skript bei Dir aus? Standardmässig werden am Druck-Ende die Achsen überhaupt nicht irgendwohin bewegt. Das macht die Firmware, wenn von SD-Karte gedruckt wird, oder in Deinem Fall wahrscheinlich der Repetier-Server.

    Im Prinzip sollte das allerdings keine Rolle spielen, weil im Start-Skript alle Achsen auf die Home-Position fahren und ab da sollte alles passen. Zumindest ist das im Start-Skript für Cura so definiert. Wenn Du mit Repetier dafür etwas anderes benutzt... dann zeig mal her... *|

     

  • Link to post
    Share on other sites
    Posted (edited) · Komisches Problem mit TinkerGnome beim Homing der Z-Achse

    Nix wildes,. In Repetier-Server sind alle Script Fenster leer, der macht also nix. Aktiv ist eigentlich nur Standard S3D Profil:

    Start
     

    G28 ; home all axes
    G1 X5 Y10 F3000 ; bring extruder to front
    G92 E0 ; zero the extruded length
    G1 Z10 ; lower
    G1 E19 F200 ; purge nozzle quickly
    G1 E26 F60 ; purge nozzle slowly
    G92 E0 ; zero the extruded length again
    G1 E-5.5 F400 ; retract
    G1 X190 Z0 F9000 ; pull away filament
    G1 X210 F9000 ; wipe
    G1 Y20 F9000 ; wipe
    G1 E0 ; feed filament back

    Ende:
     

    G28 X0 ; home the X-axis
    M104 S0 ; turn off heaters
    M140 S0 ; turn off bed
    M106 S0; turn off fan
    M84 ; disable motors

    Das Druckende selber ist auch nicht das Problem, will sagen: da passiert nix unerwartetes. Der Start des Nächsten Drucks, da läuft es dann beim G28 schief, er homed, läuft in den Endstop und ist dann aber der Meinung, der Endstop wäre bei ca. 200mm erreicht und nicht bei 212mm. Soll ich mal ne Kamera davor stellen, hilft das?

    (Der Drucker ist übrigens der Meinung, z wären 230mm, ist das korrekt oder unwichtiger Nebenschauplatz?)

    Edited by StephanK
    edit: z natürlich, nicht y
  • Link to post
    Share on other sites
    Posted · Komisches Problem mit TinkerGnome beim Homing der Z-Achse
    3 hours ago, StephanK said:

    (Der Drucker ist übrigens der Meinung, z wären 230mm, ist das korrekt oder unwichtiger Nebenschauplatz?)

     

    Der Default für Z_MAX_POS  ist 230, das passt schon.

    Ein M503 schreibt die gespeicherten Werte auf die (serielle) Konsole (ich nehme an, Repetier-Server zeigt so etwas auch an?).

    Das sollte dann als "Home offset" für Z die Differenz zu Deinen 212,25 ausgeben (also 17,75 mm). Wenn möglich, kannst Du das vor jedem Druck mal versuchsweise prüfen, damit sollte man herausbekommen, ob da irgendwas zwischendurch verstellt wird (oder ob das ausgeschlossen werden kann :))...

     

  • Link to post
    Share on other sites
    Posted · Komisches Problem mit TinkerGnome beim Homing der Z-Achse

    Ja, Serielle Konsole ist vorhanden. Ich werde das nun vor jedem Druck prüfen und berichten.

    Ich hab vorhin mal die Kamera mitlaufen lassen, weil  man sehr schön im Display sehen kann, wenn es schief läuft - aber da ist das Problem natürlich nicht aufgetreten.

    Ich bleibe dran und melde mich, sobald ich neue Erkenntnisse habe.

    Vielen Dank auch Dir für die Hilfe (und die geniale Software natürlich sowieso)

  • Link to post
    Share on other sites
    Posted (edited) · Komisches Problem mit TinkerGnome beim Homing der Z-Achse

    Tja, da bin ich wieder.. jetzt ging es wochenlang problemlos, heut morgen wars dann wieder soweit. Wollte eigentlich mit Change Material das Filament wechseln, dabei wurde der Y-Endstop nicht erkannt (der beim normalen "Home Head" auch direkt anschliessend funktioniert hat) und unter großem Geratter hab ich dann mal schleunigst auf Cancel gedrückt. 

    Interessant dabei ist vielleicht die Displayanzeige unter Move Axis:
    20180216_075306671_iOS.thumb.jpg.b8e8589f5a82cf86c6af2dbceac452e8.jpg

    Pos. Y ist glaub klar so nicht gedacht, Pos Z ist wieder der etwa cm zuwenig. Home bringt keine Änderung. Nach ein & Ausschalten des Druckers passte es dann wieder alles und auch Change Filament funktionierte wieder normal.
     

     

     

    Edited by StephanK
  • Link to post
    Share on other sites
    Posted · Komisches Problem mit TinkerGnome beim Homing der Z-Achse

    Hallo

    Welche Firmware Version hast du den drauf?

    Ist der Fehler erst nach ein Firmware Update aufgetreten?

    Bin ein Freund von Version 16.03 die läuft bei mir ohne Probleme

     

    Gruß

  • Link to post
    Share on other sites
    Posted · Komisches Problem mit TinkerGnome beim Homing der Z-Achse

    Ich hab 17.10.01 drauf. Mit der original UltiMaker Firmware nie ein Problem gehabt. Eventuell gehe ich doch nochmal zurück auf 16.03.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...