Jump to content
Ultimaker Community of 3D Printing Experts

UM3 fw update without lan (with usb)

Recommended Posts

The steps are as follows:

1. Download the stable and stable signature files

2. Copy the 2 files to the root of your USB stick, insert usb stick into the printer

3. Use the printer's UI to navigate to SYSTEM → Maintenance → Update firmware

4. Then select the file you just put on your USB stick (note: only one option is shown per set of 2 files, the *.tar.xz option).

5. Wait for the update to be installed; follow the instructions on the screen.

Share this post

Link to post
Share on other sites

Don't extract the files, leave them in the state as downloaded.

Note that this printer's menu doesn't update automatically when you insert the usb stick, you will only see the usb stick if it was already present when you entered the firmware update menu, otherwise you will have to go up one menu level and return again.


What is the firmware version on your printer?

When you copy a gcode file to this USB stick, is that being recognized when you enter the print menu? Some usb sticks have multiple partitions and we are only looking at one partition.

Edited by Indy31

Share this post

Link to post
Share on other sites

First i tried withouth extracting, then i tried with extracted files.

My usb stich is used to print all my Gcode files. I tried with all situations, formated disk, only the 2 files on it, booting with and withouth usb stick.

... Fw version i will look into tomorrow (i thought something like 3.6....)



Share this post

Link to post
Share on other sites

Just another thought since you mentioned you unzipped the file....

On Windows some versions of Internet Explorer are known to change the file extensions. I just tested on my old Windows 7 and IE11. These are the results:

"latest.tar.xz" was saved as "latest.tar.tar"

"latest.tar.xz.sig" became "latest.tar.xz.tar"


Rename the files again to have the original extensions.

Share this post

Link to post
Share on other sites

You have an intriguing problem...

I studied the release notes since your v3.5.3 but nothing there that explains your problem.

Then I created a clean installed printer with v3.5.3 and when I insert a usb stick with the firmware files on it, these are recognized.


You are the first one to report this problem on an old software version where many people already updated successfully. You are doing something different, I just can't figure out what.

Instead of spending more time in figuring out your problem, is it possible for you to move the printer to another location where you can plug in the network cable and do the update over the internet?

The other option is to follow the procedure for a bricked machine, but that involves quiet some work.

  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 87 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!