Jump to content
Ultimaker Community of 3D Printing Experts

Assemblage dans cura


Recommended Posts

Posted (edited) · Assemblage dans cura

Bonjour,

 

J'ai vraiment de la difficulté à effectué un simple assemblage dans Cura, pourtant dans solidwork j'ai bien validé qu'elles sont bien aux bonnes positions par rapport à l'origine. 

 

 

Pièce mâle

2.1.png

1.png

2.png La pièce est bien centrée à l'origine

 

Pièce femelle

3.png

4.pngLa pièce est bien centrée à l'origine

 

Assemblage dans solidwork en important uniquement les deux pièces, je n'impose pas la moindre contrainte n'y le moindre déplacement, en les importants elles s'assemblent parfaitement. 

4.1.png

 

j'importe les pièces dans cura, j’attribue le matériel et les paramètres

5.png

 

Je les merge

6.png

 

J’effectue une rotation de l'assemblage et ... elles sont croches, j'ai effectué plusieurs tentatives de plusieurs manières et c'est toujours le même résultat.

7.png

 

Avez-vous une idée ?

 

Merci

Edited by orangesale
  • Link to post
    Share on other sites
    Posted · Assemblage dans cura


    Vérifie que l'origine de tes deux objets est la même dans SW : Cura utilise cette valeur pour placer l'objet.

     

    importe ta première pièce seule.
    positionne la en X:0 / Y:0 / Z:0

     

    importe ensuite la deuxième pièce.
    Positionne la en X:0 / Y:0 / Z = distance entre la base de ton premier objet et la base de ton deuxième objet.

  • Link to post
    Share on other sites
    Posted (edited) · Assemblage dans cura

    Tu as une case à décocher dans les préférences de CURA pour éviter ça...

    Edited by darkdvd
  • Link to post
    Share on other sites
    Posted · Assemblage dans cura

    Comme l'a dis @darkdvd l'origine dans le logiciel de CAO est déterminant.

     

    Aussi j'ai remarqué qu'il vaut mieux ne pas faire de transformations sur le fichier dans Cura avant le merge (rotations, mise à l'échelle), est ce que tu as fait quelque chose à ce niveau la?

     

    Quand tu exportes le STL (je ne connais pas SW) est ce que tu es bien dans les positions adéquates?

  • Link to post
    Share on other sites
    Posted · Assemblage dans cura

    Oui les positions sont bonnes tel qu'illustré sur les photos, je ne fais aucune manipulation avant le merge

  • Link to post
    Share on other sites
    Posted · Assemblage dans cura

    Ça a fonctionné en les plaçant manuellement dans cura (0-0-0) (0-0-3.81) 

     

    Merci Darkdvd...

    • Thanks 1
    Link to post
    Share on other sites
    Posted · Assemblage dans cura

    Salut!: )

     

    3,81 manuellement c'est un peu au pif ?^^

     

    Je n'arrive pas les centrés correctement...

     

    Les origines sont bien les mêmes dans SW. -> Fonction empreinte sur le système de coordonné basé sur l'origine !?

     

    J'ai tenté un stl à la fois sans le merge...rien !

     

    J'ai le sentiment que l'origine est déplacé pendant la création du stl ?!

  • Link to post
    Share on other sites
    Posted · Assemblage dans cura

    Il me semble qu'il faut éviter toutes les manipulations du modèle dans Cura (genre mis à échelle, ou déplacement) avant de faire le merge (à voir).

    • Like 1
    Link to post
    Share on other sites
    Posted (edited) · Assemblage dans cura

    Ce qui n'arrange pas les choses , c'est que mes objets ne tiennes pas tous les deux sur le plateau, il faut qu'ils soient assemblés.

    Profil um2+ ou um3+ ne change rien.

     

    Dans la création de stl avec Solidwork on peut "renforcer l’emplacement de l’origine" par un systèmes de coordonnées établis que j'ai positionné...mais ça ne change rien !?

     

    Sur Simplify  3D, ce problème est gérable ? Je vais devoir l'acheter !

     

    Le truc est que quand je charge l'ensemble ou un par un, mes stl sont séparés volontairement par cura .

    Donc je suis obligé de les déplacés.

     

    Ils sont positionnés :

     

    1-X=0 / Y=0 / Z=0

    2-X=200 / Y=100 / Z=0

    Edited by Guillaume777
  • Link to post
    Share on other sites
    Posted · Assemblage dans cura

    C'est bon j'ai trouvé une méthode qui n'est pas parfaite car elle ne s'appuis pas sur des points d'origines.

    Mais ça me convient.

     

    Il suffit de crée une gabarit non imprimable autour du second objets prenant en compte 4 faces.

    J'ai fait une un ruban surfacique de 10 mm sur les deux plans . Cela ressemble à un ruban de "papier cadeau".

     

    Cura s'appuis sur le volume de l'objet dans mon cas et l’origine.

     

    En espérant qu'ils pourront crée une fonction s'appuyant sur les origines.

    Du moins qu'elle soit préservé pour les manipulations.

  • Link to post
    Share on other sites
    Posted · Assemblage dans cura
    2 hours ago, Guillaume777 said:

     

    Le truc est que quand je charge l'ensemble ou un par un, mes stl sont séparés volontairement par cura .

    Donc je suis obligé de les déplacés. 

     

     

    par hasard tu n'as pas cette case de cochée ?

    Capture2.PNG

    • Like 1
    Link to post
    Share on other sites
    Posted · Assemblage dans cura

    L'option était déjà bien décoché !; ) 

    Mes objets sont trop volumineux pour tenir désassemblé sur le plateau.  

  • Link to post
    Share on other sites
    Posted · Assemblage dans cura

    Et si tu importes tes objets en même temps sans tenir compte qu'ils soient ou pas sur le plateau (donc imprimable) et tu fais un "merge" ensuite ?

  • Link to post
    Share on other sites
    Posted (edited) · Assemblage dans cura

    Il y a plus de décalage que si je fais un déplacé (sans le ruban surfacique) X=0,  Y=0, Z=0 ! ; )

    Edited by Guillaume777
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...