Jump to content

Cura 3.3 completely broke USB connection with CR10 S5


jkushwara

Recommended Posts

Posted · Cura 3.3 completely broke USB connection with CR10 S5

I've had an ongoing issue that's prevented me from using Cura at all since installing 3.3 with my CR10S5. I'd been running 3.2.1 just fine and printing via USB. After installing 3.3 the print from usb option would not display, and the monitor showed no connection. Tried using 3.2.1 again and the same result - can't connect to the printer at all now with either 3.2.1 or 3.3 . Tried deleting the machine profiles, and re-adding them again with no luck. Any suggestions ? Would I need to completely un-install both versions and re-install 3.3 - and are there user preference files that I would need to delete for a fresh install ? 

 

Simplify 3D is able to connect to the same printer through USB with no issues, so it's not hardware related. 

  • Link to post
    Share on other sites

    Posted · Cura 3.3 completely broke USB connection with CR10 S5

    windows/mac/linux?   The com port is probably tied up for some reason.  You could reboot or kill all processes that might be using the com port (some version of cura might be semi-crashed but locking up the com port).  When you plug the usb into the computer (if it's windows) you should hear a particular sound (ba dunk).  where the second not is a higher pitch.  When unplug it is almost the same sound but the pitch goes down.

     

    When you hear the upward pitch you can open device manager (on windows) and you should see a USB service pop up and then dissapear and a COM service pop up.  Check that all that is working to simplify if the issue is maybe not related to cura at all.

     

    If you have windows I strongly recommend using cura to slice but then use pronterface to print over USB.  It has amazing features.

  • Link to post
    Share on other sites

    Posted · Cura 3.3 completely broke USB connection with CR10 S5

    Thanks gr5 ! Windows 2010 . I resolved it by uninstalling both versions, and manually deleting all the cura pref files from my user directories. Reinstalled 3.3. and was able to connect.  Just out of curiosity, I then reinstalled 3.2.1 and that wouldn't connect at all. Seems like once the printer is added to 3.3 it won't allow a connection to 3.2.1 ?

     

    Will definitely check out pronterface ! Thanks for the tip. I've been wanting to find a good controller that updates in real time. S3D's control panel is great -  it's slice preview updates with the print layer by layer, displays the Gcode as it's being sent and offers a nice set of machine jogging controls. 

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
         
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    ×
    ×
    • Create New...