Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Printer has two fans, fan0 is hot end fan and has temperature control set and comes on at 45C. Fan1 is print cooling fan. Printing ABS I only want hot end fan on. Untick cooling and it sends M107 which turns off fan0. Is there any way in cura to define fan numbers? Tried on both Cura 3.3.1 and 3.4 beta.

Share this post


Link to post
Share on other sites

Maybe a bug, but post processing plugin does absolutely nothing in 3.3.1 or 3.4Beta. Possibly because my install is 64bit, if the plugings are not compatible they wont work. Several other plugins don't work either.

Share this post


Link to post
Share on other sites

https://reprap.org/wiki/G-code#M106:_Fan_On

M106: Fan On
Parameters

Pnnn Fan number (optional, defaults to 0)2
Snnn Fan speed (0 to 255; RepRapFirmware also accepts 0.0 to 1.0))
Extra Parameters
Innn Invert signal, or disable fan1
Fnnn Set fan PWM frequency, in Hz1
Lnnn Set minimum fan speed (0 to 255 or 0.0 to 1.0)1
Bnnn Blip time - fan will be run at full PWM for this number of seconds when started from standstill1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!