Jump to content
TK_HPU

Command line execute CuraEngine, How to Generate T0&T1 ?

Recommended Posts

Posted · Command line execute CuraEngine, How to Generate T0&T1 ?

I execute CuraEngine.exe by command line. The version is 3.3, I use ultimaker3.def.json and  ultimaker3_extruder_left.def.json and ultimaker3_extruder_right.def.json. 

Now it is only one extruder, even though it have generate support.

How to modify the .json file, so that it can use both extruder1 and extruder2.

I mean, I want extruder1 be used for the model, the extruder2 be used for support.

Is there any demo?

Thanks!

 

Share this post


Link to post
Share on other sites
Posted · Command line execute CuraEngine, How to Generate T0&T1 ?

You need to set the setting "support_extruder_nr" to 1 (instead of 0, which is the default)

If I recall correctly, this can be done by adding;

-s support_extruder_nr="1" 

 

Share this post


Link to post
Share on other sites
Posted · Command line execute CuraEngine, How to Generate T0&T1 ?
3 hours ago, nallath said:

You need to set the setting "support_extruder_nr" to 1 (instead of 0, which is the default)

If I recall correctly, this can be done by adding;


-s support_extruder_nr="1" 

 

Thanks!

I have tried 3 ways:

 

(1) Not modify anything of the fdmprinter.def.json, just add the command  '-s support_extruder_nr="1" '

It is not help.

 

(2) Just modify the dmprinter.def.json, as this:

image.thumb.png.877e756f49ff5ca41270e2935c431fdc.png

 

It is not help. Just like this:

image.thumb.png.98ec4e5bed21904446a43b01f4f291a8.png

 

 

(3) If I modify the default value of "support_infill_extruder_nr", like this:

image.thumb.png.68f5b38833a1cc77c39b2c0babcd2665.png

 

It worked! But, there is an additional cylinder!As this:

image.thumb.png.3b5afccfad39191ea11d59f3e564881c.png

 

 

 

Here is my json file.

Thanks!!!

 

json_file.zip

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!