Jump to content

UMO Not Heating Hot End?


Recommended Posts

Posted · UMO Not Heating Hot End?

I've got one of the very early Ultimaker Originals (back when they were just called "Ultimaker"). It's got version 1.5.4 electronics, and has had a few bits and bobs added over the years, most notably a heated bed. It's been packed in a box for about 3 years, before which it definitely worked. Somewhat foolishly, I immediately upgraded the firmware, although maybe I should have tried it before I did that.


Long story short: it's not attempting to heat the hot end. There's an LED which lights when the heater is on, and this never lights up. The temperature sensor seems to be working (it reads about 30C, even though the room is at about 21C, but it always seemed to do that) - if I squeeze the aluminium block in my fingers, I can get the temperature to go up a couple of degrees.


However, no matter what I try, I don't seem to be able to convince it to actually turn the heater on. I've got a good looking 19V power supply, my 12V line looks good too, the fans are all working, the green LEDs on the board are on, the blue LED strips are on, the little blue LED in the head is on, Cura 'sees' the printer (although I can't 'jog' the head, I can press the home buttons and it moves). I've tried firmware for the UMO, UMO+ with and without the heated bed option.


Not ideal, but not a concern right now is that the heated bed (which is a 3rd party 24V alu board + glass bed) reads 1100C - doesn't matter if it's connected or not. It doesn't seem to matter if I check the "Heated Bed" box in the settings or not, it always shows it, and it's always wrong. Once the hot end is sorted, this will probably be my next job to fix...


This problem *feels* like firmware/compatibility/my ancient kit, but I can't see any options anywhere to fiddle with those details. Any help much appreciated!

  • Link to post
    Share on other sites

    Posted (edited) · UMO Not Heating Hot End?

    The first thing I would do was to measure the terminals for the hotend heater when the printer is supposed to be heating... Do you have power on that? If you do, either the hotend heater wire or heater itself is broken and you can just buy a new one for really cheap and replace it.
    If not, maybe the terminal is broken, but since you wrote that you updated the firmware, I think its much more likely an error in there... Where did you get the firmware from, can you send or post the configuration.h file?


    Edited by tommyph1208
  • Link to post
    Share on other sites

    Posted · UMO Not Heating Hot End?

    Thanks for that - I get zero volts across the two heater terminals - but then, as the light doesn't come on, it means that the board isn't even trying to heat (it took me a few minutes for 'the penny to drop' last night when I was looking at it). I do have 12V available, so when it tries to heat, it'll (hopefully) get some volts though.


    The most obvious problem is when you get a crazy temperature reading the board doesn't heat because it may overheat the head. However, in this case the temperature reading isn't super accurate, but it is reasonable, and does change with temperature, so it doesn't seem to be that.


    As for firmware - I just pressed the 'upgrade firmware' button in Cura (which is the latest version I could get (v3.5.1). Not sure I can get a .h from any of that?


    In some desperation, I'm going to try and resurrect my old computer, which (hopefully) has the old version of Cura on it, which hopefully has the old firmware on it - not sure how successful any of that will be, but it might work.

  • Link to post
    Share on other sites

    Posted · UMO Not Heating Hot End?

    You can also get the arduino IDE and just build and upload a version of Marlin yourself... 
    You can find it on GitHub...
    I have previously used marlin builder tools as well, which basically lets you set up all the things you need in a nice layout without having to mess around in configuration files etc. There is a guide to that in the Tips and Tricks section on the Ultimaker website:

  • Link to post
    Share on other sites

    Posted · UMO Not Heating Hot End?

    The Marlin Builder seems to be the way to go - I more or less used the defaults, apart from guessing the temperature sensor of my heated bed. I built the firmware and uploaded it, and now the 'jog' functions all work, the heated bed is reading a sane value and the hotend (and bed) heat up when asked to do so. I haven't actually tried a print with it yet - that'll have to wait until the weekend.


    That worked out a lot easier than I thought it would - although I wonder why Cura's UMO firmware didn't at least make the basic printer work...? (I'd excuse it not working with the heated bed, as that's a bit custom/3rd party).


    Either way - thank you very much for your help - much appreciated.

  • Link to post
    Share on other sites

    Posted · UMO Not Heating Hot End?

    No problem man, glad you got it working :)


  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    • Create New...