Jump to content
UltiMaker Community of 3D Printing Experts

Squares in custom g-code box


boogieman
 Share

Recommended Posts

Posted · Squares in custom g-code box

I almost spent two days now figuring this out, but i don't know how to fix it.
The problem is i see squares instead of text in the custom g-code box. I run Cura 3.6 under ubuntu 16.4 with xfce window manager. 
If i start cura with admin rights i can see the text just fine.

Any ideas?

 

Screenshot_2019-02-19_23-30-08.thumb.png.e30512f3d223abca6e58b07a5a933747.png

  • Link to post
    Share on other sites

    Posted · Squares in custom g-code box

    oh, wow. I've never seen it do that before (which is one of those things you never want to hear from any engineer I guess).

    Could you share your logs? I don't think there is going to be anything in there that is usefull in there, but it's worth a shot.

  • Link to post
    Share on other sites

    Posted · Squares in custom g-code box

    here they are. The cura.log is just a copy of both stderr and stdout, i guess.

    What i forget to mention is that i tried to see the file accesses of both the user and root program run. But i couldnt find something promising with lsof so far.
    I also tried strace which didn't work because it makes cura freeze. But i'm not experienced with strace so i don't know if you could give some valuable information. 

    stdout.log

    cura(shortened).log

  • Link to post
    Share on other sites

    Posted · Squares in custom g-code box

    Well, that shows that my memory is rubish.

  • Link to post
    Share on other sites

    Posted · Squares in custom g-code box

    Finally, its solved! Thanks guys. This has shown the way and has lead me to 
    http://perlstalker.vuser.org/blog/2011/12/19/setting-default-monospace-font-xfce/
     

    My Problem was somehow in the $HOME/.fonts folder. There were some monospace fonts (.ttf and .otf) of some older Powerline installation. I just got rid of the folder and now the squares in the GCode section are gone!
    Powerline seems to work as before.

     

    🙂

  • Link to post
    Share on other sites

    Posted · Squares in custom g-code box

    This solved the problem:

    https://github.com/Ultimaker/Cura/issues/2452#issuecomment-613903842

     

    Quote

    Linux Mint 19.2 Cinnamon
    Same problem, sudo apt purge fonts-powerline fixes the problem.

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...