Jump to content
DivideByZero

Settings visibility

Recommended Posts

Posted · Settings visibility

Hi,

 

Had a look in the manual, but still not clear on this...

 

If a setting is not visible, is it not in use? Or does it just run at the Cura default?

 

For 2 examples.

 

1) If travel speed is not visible in Cura, will it use the default travel speed in my printers firmware?

 

2) If Jerk control is Enabled, but the settings are not visible - would that be using my printer firmware defaults, or just unseen Cura settings?

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Posted · Settings visibility
16 minutes ago, DivideByZero said:

If a setting is not visible, is it not in use? Or does it just run at the Cura default?

 

No, a setting's visibility has no effect on whether it is used or not by Cura. All the settings have a default value which may or may not be suitable for a given print job.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Settings visibility

Ah, so even if a setting is not visible, it could still be doing something in the background - you just can't see the values.

 

Is there a way to reset all the values to their defaults? Or is it a case of uninstall / re-install?

Share this post


Link to post
Share on other sites
Posted · Settings visibility
27 minutes ago, DivideByZero said:

Ah, so even if a setting is not visible, it could still be doing something in the background - you just can't see the values.

 

Correct.

 

27 minutes ago, DivideByZero said:

Is there a way to reset all the values to their defaults? Or is it a case of uninstall / re-install?

 

Not sure that an uninstall will actually remove your settings. Someone who knows the Cura front end better than me needs to answer your question. It does seem somewhat of an omission that there isn't a "reset profile to defaults" option.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Settings visibility

Well, trying the reinstall - first question is if you want to remove all your settings... which I do, I really do.

 

I am unable to print without strings. I have been working on the settings and nothing is helping, so I am hoping something was changed in Cura at some point which is messing me up.

 

Retraction, esteps, jerk, travel, speed, temp, coasting... tried it all (and probably more), still stringing. Please be something I did in Cura…!

Share this post


Link to post
Share on other sites
Posted · Settings visibility

here's a list of all folders to delete to get a real clean install;

https://github.com/Ultimaker/Cura/issues/3051

 

And are you aware of the visibility settings button? you may want to select "show all" to see if there are messed up settings..

The settings not shown by default can indeed F@#$up you print...  I particularly always check for crazy speeds, like to fast infill speeds...

 

image.png.06b25c9f8f49e99ddc88bb6203e0e492.png

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited) · Settings visibility
8 hours ago, ultiarjan said:

 

And are you aware of the visibility settings button? 

 

Hehe, yeah thanks.

 

That's actually kinda why I asked the question. A while back I got fed up with adding settings here and there so clicked the show all option. What I was worried was by doing that, I activated a lot of things I didn't need. Guess that was not the case, I must have changed something somewhere that had a knock on effect.

 

For me, I backed up c:\users\myuser\appdata\roaming\cura and then uninstalled Cura. It asked me if I want to delete all my settings too, which I said yes to.

 

Since reinstall and all the settings being back to day one, things are looking a lot better... though I still need to do some more tinkering. However, today I also found the basic\advanced\expert views you mentioned, so I am sticking with Advanced and just adding what I need to start with so I don't get tempted to fiddle with too much in one go.

 

Thanks for your help everyone.

 

P.S. I did get a 99% string free print out on my 2nd try after reinstall - best I had before that was 95% or so, often much worse.

Edited by DivideByZero

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 17 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!