Jump to content
Vampora

Not printing correctly after last firware update

Recommended Posts

Posted · Not printing correctly after last firware update

So just caught up on a bunch of firmware updates. I went all the way to the lastest one. Now when I print it tries to print a good 25mm or so above the bed for some reason. Any ideas? If it matters I am using hardcore nozzles, tried cura 3.6 and 4.0, and it was working perfectly fine before the firmware update. It must know where it is though because the prime goes to the correct spot.

Share this post


Link to post
Share on other sites
Posted · Not printing correctly after last firware update

The reason for it is a command in the gcode G92 Z, this is causing the problem. Normally G92 Z comes from the Z-height plugin, but there are also users without that plugin. You can try to install a fresh copy of Cura 4 and delete the configuration folder before.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted · Not printing correctly after last firware update

I am using the z height plugin. So after this will I not be able to use it? Or do I need to do a fresh install and then install it? Without it I cant use the hardcore nozzles as it prints too close to the bed and jams.

Share this post


Link to post
Share on other sites
Posted · Not printing correctly after last firware update

By deleting the config does that get rid of all my other printers again? I normally wouldn't care, but I just got done entering them all again 2 weeks ago. 

Share this post


Link to post
Share on other sites
Posted · Not printing correctly after last firware update

I figured it out. Thank you so much! That was definitely it.

Share this post


Link to post
Share on other sites
Posted · Not printing correctly after last firware update

I'm probably too late now, but if you delete the config folder, all your settings will be gone. You might want to copy it away first, then you have the chance to copy back the configs step by step.

 

But if you're using the z-height plugin, it's probably enough to just disable this plugin. The reinstallation was helpful for users who had the problem but didn't use the z-height plugin.

 

Where the problem is with G92 Z is still unclear, so the plugin is not usable for now. But I'm sure the problem/bug will be analyzed and hopefully fixed with the next Cura update.

 

Share this post


Link to post
Share on other sites
Posted (edited) · Not printing correctly after last firware update

I had the same issue: used the Z-as plugin for finetuning bedleveling, worked great !

But after this new firmware upgrade, the printer is printing in the AIR (about 3cm too high!!).

Now disabled the plugin, it prints now on the glass again 😉

 

BUT: it's a BUG, I hope they will fix it asap !!

Edited by knutselsmurf

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 65 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!