Jump to content
Ultimaker Community of 3D Printing Experts

Preheating in Cura. First Heatbed, second Nozzle?


Recommended Posts

Posted · Preheating in Cura. First Heatbed, second Nozzle?

Hi Daid,

is it possible to change the preheating from first nozzle to first heatbed in cura?

While the time for heating the nozzle is about 2 minutes and the time for the heatbed is about 10 minutes and in that time the filament is melting away. :)

Regards

Thomas

 

  • Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?

    Not good! Sometimes if you overheat pla and don't print for too long it causes a jam in the print head.

    Maybe you should turn on your heatbed. Walk away and then after 10 minutes start your print.

    Personally I always set the temperatures in Cura all to 0. This makes it so that Cura doesn't wait and just starts printing when you tell it to. Instead you have to set the temps manually (either with ulticontroller or with Cura printing window).

     

  • Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?

    Cura currently heats up both at the same time. However, you can change this behavior.

    Put the following code at the top of the start.gcode:

     


    M190 S{print_bed_temperature}
    M109 S{print_temperature}

    Cura will see the {} tags in the start code and will not emit the default heatup commands.

     

  • Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?

    @Daid

    Thank you very much for setting it in the start.gcode.

    It works with one nozzle, but not with the second nozzle.

    Until now, I always changed the sequence of the Mxxx in gcode, but it would be better to set it in cure before. :)

    e.g. from:

    M140 S50.000000

    M104 T1 S210.000000

    M109 T0 S215.000000

    M109 T1 S210.000000

    T0

    M190 S50.000000

    to:

    M140 S90.000000

    M190 S90.000000

    T0

    T1

    M104 T1 S200.000000

    M104 T0 S235.000000

    M109 T1 S200.000000

    M109 T0 S235.000000

     

    Works very fine, because the two nozzles are heating at the same time, after bedheating.

     

    @gr5

    Thank you for the link.

     

  • Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?

    @Daid

    I set this at the top of the start.gcode.

    M140 S{print_bed_temperature}

    M190 S{print_bed_temperature}

    M104 T0 S{print_temperature}

    M104 T1 S{print_temperature}

    M109 T0 S{print_temperature}

    M109 T1 S{print_temperature}

    In cura are two different temp´s of the nozzles.

    But cura set all temp´s at T0. :(

    What´s wrong with the start.gcode?

     

  • Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?

    I think you need to do:

    M140 S{print_bed_temperature}

    M190 S{print_bed_temperature}

    M104 T0 S{print_temperature}

    M104 T1 S{print_temperature2}

    M109 T0 S{print_temperature}

    M109 T1 S{print_temperature2}

     

  • Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?

    That's it. :)

    It works fine now .

    Thank very much.

     

  • Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?

    Hi, I have tried putting the above code at the end of my start code. Unfortunately it won't work for me. I am using one extruder and heat bed, and my bed takes ages to get hot, so I need for the nozzle to start heating after the bed has reached it's final temp.

    With the code above, it does start heating the bed first, but after it reaches the final temp, nothing happens. The extruder does not warm up so it gets stuck there, just mantaining the bed temp.

    Any suggestions, please?

    Thx in advance

     

  • Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?

    Latest versions of Cura do bed-first by default now. So you don't have to change a thing then.

     

  • Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?

    Great to see that! I had a recent version but now that I downloaded the latest one I can see it's in the changelog. It makes so much more sense now.

    Thank you

     

  • Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?

    Well, I have a different problem now, when I print via USB it works as expected, heating bed first, great!

    However if I print with SD card, the same gcode heats bed and just stays like that forever keeping bed temp. It does not start heating the nozzle.

    Anyone else having this problem or know possible cause and solution?

  • Link to post
    Share on other sites
    Posted (edited) · Preheating in Cura. First Heatbed, second Nozzle?
    On 1/11/2015 at 1:08 PM, Daid said:

    Latest versions of Cura do bed-first by default now. So you don't have to change a thing then.

     

     
     
    And what can you do to make the bed back heated only after the head?
    Cura inserts the code into the gcode:
    ; Generated with Cura_SteamEngine 3.6.0
    M140 S60
    M105
    M190 S60
    M104 S200
    M105
    M109 S200
    It adds its own code to Start G-code:
    M104 S {print_temperature}
    M105
    M109 S {print_temperature}
    M140 S {print_bed_temperature}
    M105
    M190 S {print_bed_temperature}
    And Cura to gcode now saves:
    ; Generated with Cura_SteamEngine 3.6.0
    M140 S60
    M105
    M190 S60
    M104 S200
    M105
    M109 S200
    M82; absolute extrusion mode
    M104 S200
    M105
    M109 S200
    M140 S60
    M105
    M190 S60

    Which, of course, makes no sense.


    Is it possible to somehow disable Cura inserting the code for heating the head and table so that only my code from the Start G-code will be left?

     

    Edited by Goral
  • Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?
    21 hours ago, Goral said:

    Is it possible to somehow disable Cura inserting the code

    Yes, by using the correct replacement patterns in your start gcode. If Cura sees the actual use of the replacement pattern {material_print_temperature} in your start gcode, it will not add its own extruder preheating. Same with {material_bed_temperature} for the bed. And I mean that actual text, including the curly braces.

    • Thanks 1
    Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?

    Thank you very much. It works!!!

  • Link to post
    Share on other sites
    Posted · Preheating in Cura. First Heatbed, second Nozzle?
    ; Ender 3 Custom Start G-code
    
    M140 S{material_bed_temperature_layer_0} ; start heating bed
    
    M104 S170 ; start heating extruder but avoid oouzing
    
    G28 ; home axis while heating
    
    M420 S1 ; enable BL mesh
    
    G1 Z10 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    
    G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
    
    M190 S{material_bed_temperature_layer_0} ; wait for bed
    
    M104 S{material_print_temperature_layer_0} ; start heating extruder
    
    M109 S{material_print_temperature_layer_0} ; wait for extruder
    
    G92 E0 ; Reset Extruder
    
    G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
    
    G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
    
    G1 X0.4 Y40 Z0.3 F1500.0 E25 ; Draw the second line
    
    G1 X0.4 Y20 Z0.3 F1500.0 ; Draw the second line without filament
    
    G92 E0 ; Reset Extruder
    
    G1 Z3.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed

     

    try this

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...