Jump to content
rob0213

Bug - Cura 4.1.0 - Combing setting backwards

Recommended Posts

Posted · Bug - Cura 4.1.0 - Combing setting backwards

Hello All:

 

I have discovered a bug and confirmed it by reviewing the generated G Code file.  In the settings where combing is enabled it is supposed to generate retractions however its backwards.

 

Combing = ON = No retractions and lines smeared on print during moves.  Combing = OFF = Retractions are done.

 

Below is a sniped of the code during what should be the first retraction - pay attention to the "E" value as it subtracts during one then goes back afterwards.

 

Set to ON but does not retract:

 

G1 X71.076 Y51.374 E60.18242
M204 S5000
G0 F3600 X72.058 Y50.226
G0 X73.208 Y49.483
G0 X126.68 Y50.792
M204 S2000
G1 F1800 X126.469 Y51.503 E60.23176
G1 X126.429 Y52.228 E60.28006

 

Same section set to Combing OFF - note the E value goes down then back up by 8mm which is my retract setting

 

G1 X71.076 Y51.374 E60.18242
M204 S5000
G1 F3000 E52.18242  -  This has the retraction of 8 mm
G0 F3600 X126.68 Y50.792
M204 S2000
G1 F3000 E60.18242  - now it goes back to original value
G1 F1800 X126.469 Y51.503 E60.23176
G1 X126.429 Y52.228 E60.28006

 

So somewhere a bit is flipped the wrong way when the G Code is generated....

 

Regards,

 

Rob

 

 

 

Share this post


Link to post
Share on other sites
Posted · Bug - Cura 4.1.0 - Combing setting backwards

Hello @rob0213, that's how combing is designed to work. Combing does not normally use retractions when moving the nozzle within a single part. There is a setting called something like max comb distance without retraction, when you set that to a non-zero value, combed travel moves further than that distance will use retraction. The best quality results are often achieved by setting the combing mode to not in skin and using a non-zero value for the max comb distance... Hope this helps.

Share this post


Link to post
Share on other sites
Posted · Bug - Cura 4.1.0 - Combing setting backwards

hmmm then the software that came with my machine is backwards....

 

The way I read it though when enabled it is supposed to avoid already printed areas when traveling.... it does not and smears the layer with lines.  OFF works so I am just going to keep it off.

 

In my mind retractions are a MUST for a clean print...

 

Rob

Share this post


Link to post
Share on other sites
Posted · Bug - Cura 4.1.0 - Combing setting backwards

The software is not backward, it is that it does not match your expectations.

 

As I understand it, the purpose of combing is to avoid using retractions when moving within a part by making sure any plastic extruded will fall on sections of that layer that have not yet been printed. It does that by staying within bounds of the part and not crossing anything that has been printed on that layer.

 

Reducing retraction is important because too many retractions in a short time will tend to grind down the filament.

 

What @burtoogle pointed out is that if you don’t want those extra thin lines to show on the finished surface you can set it to not comb on the skin (top/bottom) layers where it will be visible on the finished part.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!