Jump to content
aurock

Cura 4.2.0 hangs on launch

Recommended Posts

Posted (edited) · Cura 4.2.0 hangs on launch

I've installed Cura 4.2.0 on 2 computers, and can't get it to work on either one.  The first time I launch it, the splash screen loads, and hangs at 'Updating configuration.'  If I kill the process and try to launch Cura again, the icon appears briefly on the taskbar then disappears.  I get no splash screen, and the only way I know that it's running is that cura.exe is still listed in task manager.  

 

Both computers are running Windows 10 v1903 x64.  One of the computers had Cura 4.1 on it previously, which was uninstalled automatically when prompted by the Cura 4.2.0 installer.  The other computer did not have a prior version of Cura. 

 

Any suggestions would be appreciated. 

 

Edit: Cura.log attached.  The last lines of the log are:
2019-07-31 09:47:10,075 - DEBUG - [MainThread] UM.Backend.Backend._logSocketState [171]: Socket state changed to Listening
2019-07-31 09:47:11,708 - INFO - [MainThread] UM.Backend.Backend.startEngine [81]: Started engine process: C:\Program Files\Ultimaker Cura 4.2\CuraEngine.exe
2019-07-31 09:47:11,715 - DEBUG - [MainThread] UM.Backend.Backend._backendLog [101]: [Backend] Calling engine with: ['C:\\Program Files\\Ultimaker Cura 4.2\\CuraEngine.exe', 'connect', '127.0.0.1:49674', '']
 

cura.log

Edited by aurock

Share this post


Link to post
Share on other sites
Posted · Cura 4.2.0 hangs on launch

I ran the compatibility troubleshooter, and it recommended applying Windows 8 compatability settings.  With those settings in place, the application launches successfully.  Is there anything I can provide which would help identify the cause of this issue?

Share this post


Link to post
Share on other sites
Posted · Cura 4.2.0 hangs on launch

I've just discovered the same fix.

 

I seem to remember having the same problem with an earlier version as well.

 

Took me a while to remember the fix.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!