Jump to content
GenaroSVA

Supress/Disable Auto Bed Leveling for Ultimaker S5

Recommended Posts

Posted (edited) · Supress/Disable Auto Bed Leveling for Ultimaker S5

Hello,

I'm looking for a way to turn off the bed leveling before each printing. What I am trying to do is to print a new part over a previously printed PLA substrate. I need to turn it off because when I try to print, the nozzle crashes with the substrate during the bed leveling routine and it doesn't let me print.

 

I would really appreciate your help.

Thanks.

Edited by GenaroSVA

Share this post


Link to post
Share on other sites
Posted · Supress/Disable Auto Bed Leveling for Ultimaker S5

Sorry, but it is not possible to disable the active leveling on the S5.

Share this post


Link to post
Share on other sites
Posted · Supress/Disable Auto Bed Leveling for Ultimaker S5

Isn't possible to modify the gcode script to cancel the routine? 
I'm trying to figure out what command I should use maybe.

 

 

Share this post


Link to post
Share on other sites
Posted · Supress/Disable Auto Bed Leveling for Ultimaker S5

No, the active leveling is done by the firmware, before the printer reads the gcode. So there is no way to suppress it from "outside" and the firmware itself has no option to disable it. 

 

The UM3 has the option, you can switch there to manual leveling, but UM says, due to the bigger build plate it is necessary to level every time - without any exceptions or options to turn it off.

 

No chance - sorry!

 

Share this post


Link to post
Share on other sites
Posted · Supress/Disable Auto Bed Leveling for Ultimaker S5

Oh, I see. 

I also saw that there's a way to do that but involves ssh. Is that true?  Here is the link to this post

 

Share this post


Link to post
Share on other sites
Posted · Supress/Disable Auto Bed Leveling for Ultimaker S5

With ssh into the printer you can do and change anything - it is actually the firmware you are modifying there.

I don't know what you have to change or which files you need to edit, but I don't recommend to do that. You can easily brick your printer!

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Supress/Disable Auto Bed Leveling for Ultimaker S5

chiming in on this topic - 

I'm currently setting up to print with the 3D Solex hardcore + Everlast ruby nozzle on the UMS5. Our reseller told me that with the CC red core, the active leveling is automatically disabled (by the firmware I suppose). Is this true?

 

...I'd rather have my printer be "a little less reliable" and being able to disable auto-leveling every time risking that a first layer might not be perfectly consistent, than risking the nozzle and/or build plate being cracked during leveling - this might be a risk with the ruby/sapphire insert in the nozzle, or so I'm told.

 

I realize that I'm not doing it the way Ultimaker is "envisioning" it, e.g. using the CC core, but the issue is bigger to me than just using the 3DSolex core.

 

best, Niklas

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Supress/Disable Auto Bed Leveling for Ultimaker S5
44 minutes ago, neute said:

Our reseller told me that with the CC red core, the active leveling is automatically disabled (by the firmware I suppose). Is this true?

 

Never heard about that and I haven't noticed it with my CC core. When I print with the CC core, the printer is leveling as always, no difference. And this is good, because also with the CC core or 3DSolex you want to have a good first layer.

 

And I also don't understand why the ruby insert should damage something. The nozzle is just touching the glass, nothing more.

Share this post


Link to post
Share on other sites
Posted · Supress/Disable Auto Bed Leveling for Ultimaker S5
Just now, Smithy said:

And I also don't understand why the ruby insert should damage something. The nozzle is just touching the glass, nothing more.

 

Hi Smithy,

 

thanks for the quick answer.

On our machine, the nozzle is pushed against the bed strongly, to the point that it bends the rods of the xy-gantry notably when the print head is in the middle of the bed while leveling.

Knowing no better, I assume that this is intended, and the first layer comes out okay (albeit sometimes a lot thinner than I would wish). 

With a standard brass or steel nozzle, I see no problem, as the metal is softer than the glass and thus nothing should break. With the ruby nozzle, a very hard tip touches a very hard surface, and I get afraid that the less hard of the two might crack (this was, again, the statement from our reseller).

But I take it that I shouldn't need to worry about this?

 

Best regards, Niklas

Share this post


Link to post
Share on other sites
Posted · Supress/Disable Auto Bed Leveling for Ultimaker S5
1 hour ago, neute said:

But I take it that I shouldn't need to worry about this?

Yes

 

The leveling process is based on capacity, the bed moves up and the sensor measures the distance. When the nozzle touches the glass, the bed still moves a little bit up and the measurement process knows, ok now the value don't change anymore, so I am touching the glass. When watching the leveling process it looks more dramatically as it is, so don't worry about.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!