Jump to content

selecting extruder for printing


teddy04

Recommended Posts

Posted · selecting extruder for printing

Currently Cura always uses the primary extruder for single color objects.

However, if you edit the start.gcode and insert:

 


T1
M109 S{print_temperature}

at the front, it will use the 2nd extruder from that point on. (Use T0 for the primary)

 

  • Link to post
    Share on other sites

    Posted · selecting extruder for printing

    thanks for the tip.

    it working but print not working.

    whats about the offset from the 2nd extruder?

    my offset is -30;2 for the 2nd extruder to hit the same point from the first one.

    so when i start to print with the modifaction from the gcode the print starts outside from the bed.

    any ideas?

     

  • Link to post
    Share on other sites

    Posted · selecting extruder for printing

    I guess you could add a small single layer stl for the first extruder part, that doesn't do anything much, but will allow everything you really want to print to be second extruder? Maybe even make it so tiny that Cura decides not to print it at all??

    Alternatively in your start gcode, you could add this after all the homing stuff:

    G92 X-30 Y2

    This will then tell the printer that the nozzle isn't at 0,0, as it thought, but at whatever coordinate your second nozzle is at when the first one is homed. Then when the rest of the gcode positions that (first) nozzle at each point, it will really be putting the second one there.

    Depending on how you're measuring the offset between the heads, you might need to flip the signs on those coordinates. Just treat the first nozzle as (0,0), and use the coordinates of the second nozzle relative to that, with positive values being towards the right and the back, as normal.

     

  • Link to post
    Share on other sites

    Posted · selecting extruder for printing

    Alternatively in your start gcode, you could add this after all the homing stuff:

    G92 X-30 Y2

    This will then tell the printer that the nozzle isn't at 0,0, as it thought, but at whatever coordinate your second nozzle is at when the first one is homed. Then when the rest of the gcode positions that (first) nozzle at each point, it will really be putting the second one there.

     

    yeah it working..

    without any other modification. i've added some aditional speed entry but is moves quite slow

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...