Jump to content

Cura 4.4 quit working


Recommended Posts

Posted · Cura 4.4 quit working

I recently upgraded to Cura 4.4

After download it worked well for the first few times I used it.

Then it started freezing when loading preferences. Opening as Admin worked for the next few times. 

Now, opening as Admin, it'll load to a blank cura screen that lacks everything but the title bar up top. (screen shot attached)

Tried "open with" on an stl file that i have sliced in the past and i get the same result. 

Tried uninstalling and redownloading from ultimaker and downloading from gitbub with the same results. It will load but only to the blank screen.

Help Me!  

cura screen.jpg

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.4 stable released
        The full stable release of UltiMaker Cura 5.4 is here and it makes it easier than ever to remove brims and supports from your finished prints. UltiMaker S series users can also look forward to print profiles for our newest UltiMaker PET CF composite material!
          • Like
        • 58 replies
    • Create New...