Jump to content
CaptainSnowball

Too High, and Too Slow

Recommended Posts

Posted · Too High, and Too Slow

Hi All!

I have an Ender 3 Pro, modified with a Duet 2 Maestro running RepRap 3.0 Beta 12. I've also modified it to include a BLTouch. So printing it using the default (Marlin, presumably) configuration in Cura, resulted in it printing really, really slow. it also set the Z axis maybe 10 or so MM too high. that was using this start Gcode:

M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk
M220 S100 ;Reset Feedrate
M221 S100 ;Reset Flowrate

G28 ;Home

G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up
G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up

Although, I modified it to RepRap Flavor, and kinda mixed the two start Gcodes, to create this:

G28 ;Home
;G1 Z15.0 F6000 ;Move the platform down 15mm
;Prime the extruder
;G92 E0
;G1 F200 E3
;G92 E0
G1 Z2.0 F3000 ;Move Z Axis up
G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up

And the result is that it isn't unbearably slow, but the problem of being way to high on the Z axis still persists.

I did a mesh Grid with 121 points or so before all of this using the duet.218365656_Annotation2020-01-02181744.thumb.png.37a61f77c2869d07f2337cbd2f91906f.png

Shown is the Height map if it helps.

Share this post


Link to post
Share on other sites
Posted · Too High, and Too Slow

Yes, I think the slowness is down to the fact that Marlin expects some values in mm/s but other firmwares (e.g. RRF as used on the Duets) expect the values to be in mm/min. So as you have already found, you need to use RepRap flavour.

 

As for the being too high, I don't think that is a Cura problem, it's more likely to be a problem with the config for the Duet. The modified start gcode doesn't look like it is causing this issue. After homing, if you manually move the nozzle up using the Duet controls, does the height make sense? i.e the z scaling is correct?

Share this post


Link to post
Share on other sites
Posted (edited) · Too High, and Too Slow

That looks like that might be the problem.

Sending the tip to 0 using 

G1 F60 Z0

Had it a little too high. but this is still different than what it Cura did, which was much higher. also, when I set the Z offset for the BLTouch and used that command, I could've sworn it wasn't too high.

I'll investigate the settings of the Duet and get back to you.

 

Update: 2 minutes later:

looks like I put the offset as negative instead of positive. I don't know why it homed correctly this and hit Z0 properly yesterday.

Edited by CaptainSnowball
update

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...