Jump to content

Printer "glitching" causing layers to not line up and random stop/ starting


Recommended Posts

Posted · Printer "glitching" causing layers to not line up and random stop/ starting

Hi, I'm new to the forum, so please let me know if I am doing anything wrong.

I have owned the printer (Ultimaker without the updated print head) for a couple of years now and managed to solve most of the issues however I am at a loss around this one so help would be appreciated. I can't seem to find any information on google on this.

When printing the printer will stop for a second then continue, it will also print every second or third layer in a different position on the print bed. The images below show the results:


The image above shows the object we are trying to print and the settings, these have worked in the past


This image shows how it has moved, it always moves towards the front of the printer which makes me think that the steppers are losing their position or the cut off switch is activating for some reason.


This image shows an object printed early and the slant that was caused. The issue seems to be getting worse the more I print.

First I tried loading the default model and printing that, same problem occured.

I thought it may be because the belts were to tight so I tried to loosen them off, this did not help.

I then tried reloading the default firmware as I thought this may be "corrupt", as well as older versions that worked fine before hand.

Finally I tried downloading and installing Repieter as I thought a different slicer may help this, also didn't work.

I checked all the connections into the PCB, these seemed to be solid and should not cause the issue.

We are currently running white PLA at the default settings in Cura 13.11.

If you have any ideas it would be much appreciated, thanks!


  • Link to post
    Share on other sites

    Posted · Printer "glitching" causing layers to not line up and random stop/ starting

    This is *very* common. You are slipping or losing steps in X (but not Y).

    There are several causes. It's probably slipping on a pulley but lets assume losing steps for a minute. Check to make sure if you push the head around in X and Y that it feels about the same. Consider putting one drop of sewing machine oil on each of the rods. Or use a thin oil.

    More likely a pulley is slipping. Tighten all the set screws. Consider marking each shaft and each pulley to see which one is the slipping one. Most likely it is the short belt which is a bit of a pain as you have to remove the X motor to get to that one. There are 6 pulleys for the X axis alone. SIX! Not 4. Make sure you tighten the set screws on all 6. Your UM probably came with a bag of extra set screws (the silver colored ones). The black ones that come with the pulleys aren't as good (although I'm still using the black ones).

    Also while it is printing look at the short belt to the X stepper. If it is twisting back and forth in different directions then that means it is touching the wood in the back. This is very easy to fix if you are using the plastic spacers - just add a washer under each of the spacers to move the motor slightly away from the wood.


  • Link to post
    Share on other sites

    Posted · Printer "glitching" causing layers to not line up and random stop/ starting

    Check all the pulleys for the y-axis - especially the two for the short belts. They are probably slipping. You can use a permanent marker to make a mark on the pulley and the shaft together, and then watch as you print to see if the marks move relative to one another. Tighten the little set screws in the pulleys.

    It could also be due to the motors missing steps, as you say. Does it make a strange noise when the print 'stops'? Turn the printer off, and then try moving the print head by hand, using fingertip pressure on both sliding blocks for first the y-axis, then the x-axis. Both should move quite easily, and smoothly, across the whole of the bed. If one is tighter than the other, or has tight parts, then check that the belts are straight, and not twisted, or catching on the sides of the pulley, or the frame of the printer; apply light machine oil (sewing machine oil) to the acis and cross rods; and check that the wooden end caps aren't pressing too tightly on the ends of the axis rods, and stopping them turning freely.


  • Link to post
    Share on other sites

    Posted · Printer "glitching" causing layers to not line up and random stop/ starting

    Hmm, gr5 is right... it's the X axis; I said Y, because you said the problems was shifting towards the front of the printer, but the photo clearly shows it's leaning to the right, so that's the x-axis.

    So that's the belts and pulleys running left to right, and especially the short belt and pulleys on the motor in the back right corner of the printer that you need to check.


  • Link to post
    Share on other sites

    Posted · Printer "glitching" causing layers to not line up and random stop/ starting

    Actually I think it *is* the Y axis. The *leaning* part was removed and replaced onto the bed after printing was over.


  • Link to post
    Share on other sites

    Posted · Printer "glitching" causing layers to not line up and random stop/ starting

    Wow, thanks for all the feedback, I actually managed to figure out what it was right after I posted it but because I haven't hit the five posts yet I couldn't tell everyone as I needed for it to be approved. Kinda typical, you always tend to figure it out right after you ask some one.

    Turns out on the axis that is going front to back (I get confused with the letters -_-) the limit switch wire was going over the linear bearing rather than under causing it to be damaged by the friction.


    It was tricky to get a good picture but hopefully that explains it.

    This also explains why it was getting worse over time.

    Any way thanks for all your feedback and sorry I couldn't let everyone know earlier and not waste their time. Better get back to 3D printing...


  • Link to post
    Share on other sites

    Posted · Printer "glitching" causing layers to not line up and random stop/ starting

    Glad you solved it! Interesting to confirm that flaky limit switch triggers cause that behavior - I'd heard rumors. Now we know :-)

    BTW, when you look at the front of the printer (with the robot logo), X axis is left to right, and Y axis is front to back.


  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    • Create New...